Topic: Centos7 , unable to install php7.0.23

[root@localhost ~]# yum  -y install  php-common php-cli php-dba php-bcmath php-embedded php-enchant php-fpm php-gd php-imap php-intl php-ldap php-mbstring php-mysql php-odbc php-pdo php-pear php-pecl-apc php-pecl-apc-devel php-pecl-memcache php-pgsql php-process php-pspell php-recode php-snmp  php-soap  php-tidy php-xml php-xmlrpc php-zts

Re: Centos7 , unable to install php7.0.23

Error: Package: php-7.0.23-2.el6.remi.x86_64 (remi-php70)
           Requires: httpd-mmn = 20051115
         
Error: Package: php-dba-7.0.23-2.el6.remi.x86_64 (remi-php70)
           Requires: libtokyocabinet.so.8()(64bit)
Error: Package: php-snmp-7.0.23-2.el6.remi.x86_64 (remi-php70)
           Requires: libnetsnmp.so.20()(64bit)
Error: Package: php-tidy-7.0.23-2.el6.remi.x86_64 (remi-php70)
           Requires: libtidy-0.99.so.0()(64bit)
Error: Package: php-dba-7.0.23-2.el6.remi.x86_64 (remi-php70)
           Requires: libgdbm.so.2()(64bit)
Error: Package: php-imap-7.0.23-2.el6.remi.x86_64 (remi-php70)
           Requires: libc-client.so.2007()(64bit)
Error: Package: php-ldap-7.0.23-2.el6.remi.x86_64 (remi-php70)
           Requires: libsasl2.so.2()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Re: Centos7 , unable to install php7.0.23

According to question title you are running CentOS 7
According to yum output you are trying to use packages from the CentOS 6 repository

You need to install the right remi-release package.
See the Wizard instructions (top right link on this page)

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Centos7 , unable to install php7.0.23

I did according to wizard:


Command to install the EPEL repository configuration package:
    yum install h t t p s://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

Command to install the Remi repository configuration package:
    yum install h t t p: //rpms.remirepo.net/enterprise/remi-release-7.rpm

Command to install the yum-utils package (for the yum-config-manager command):
    yum install yum-utils

You want a single version which means replacing base packages from the distribution

Packages have the same name than the base repository, ie php-*

PHP version 7.0 packages are available for CentOS 7 in remi-php70 repository

If the priorities plugin is enabled, ensure remi-php70 have higher priority (a lower value) than base and updates

Command to enable the repository:
    yum-config-manager --enable remi-php70

Command to upgrade (the repository only provides PHP):
    yum update






yum  -y install  php-common php-cli php-dba php-bcmath php-embedded php-enchant php-fpm php-gd php-imap php-intl php-ldap php-mbstring php-mysql php-odbc php-pdo php-pear php-pecl-apc php-pecl-apc-devel php-pecl-memcache php-pgsql php-process php-pspell php-recode php-snmp  php-soap  php-tidy php-xml php-xmlrpc php-zts

Got errors:

--> Finished Dependency Resolution
Error: Package: php-imap-7.0.23-1.el7.remi.x86_64 (remi-php70)
           Requires: libc-client.so.2007()(64bit)
Error: Package: php-tidy-7.0.23-1.el7.remi.x86_64 (remi-php70)
           Requires: libtidy.so.5()(64bit)

Re: Centos7 , unable to install php7.0.23

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Re: Centos7 , unable to install php7.0.23

After some googling I did:

yum install h t t p://dl.fedoraproject.org/pub/epel/7/x86_64/l/libc-client-2007f-16.el7.x86_64.rpm

yum install h t t p://dl.fedoraproject.org/pub/epel/7/x86_64/l/libtidy-5.4.0-1.el7.x86_64.rpm

I do not know if that's the finest way to do thing, but I got PHP 7.0.23 installed in Centos 7.

PS.  this "Too more links in message. Allowed 1 links. Reduce number of links and post it again." is silly.

Re: Centos7 , unable to install php7.0.23

Looks like EPEL is not enabled... else yum will have found the needed dependency

to confirm: yum repolist

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Centos7 , unable to install php7.0.23

yum repolist
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: ftp.funet.fi
* epel: epel.mirror.far.fi
* extras: ftp.funet.fi
* remi-php70: mirror.23media.de
* remi-safe: mirror.23media.de
* updates: ftp.funet.fi
repo id                                 repo name                                                                             status
base/7/x86_64                           CentOS-7 - Base                                                                        9,591
epel/x86_64                             Extra Packages for Enterprise Linux 7 - x86_64                                        12,395
extras/7/x86_64                         CentOS-7 - Extras                                                                        196
remi-php70                              Remi's PHP 7.0 RPM repository for Enterprise Linux 7 - x86_64                            352
remi-safe                               Safe Remi's RPM repository for Enterprise Linux 7 - x86_64                             2,187
updates/7/x86_64                        CentOS-7 - Updates                                                                       673
repolist: 25,394

Re: Centos7 , unable to install php7.0.23

strange.

try to remove everything (php-*, libc-client, tidy, ...) + yum clean metadata + reinstall and post the full yum output.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Centos7 , unable to install php7.0.23

I'll leave it.   I did install on another fresh instance according to wizard and everything went well ...

This faulty instance got:

wget http://dl.fedoraproject.org/pub/epel/6/ … noarch.rpm
rpm -Uvh  epel-release*.rpm
wget http://rpms.famillecollet.com/enterpris … ease-6.rpm
yum -y install remi*.rpm

installed before I took the wizard instructions.

Re: Centos7 , unable to install php7.0.23

> I'll leave it.   I did install on another fresh instance according to wizard and everything went well ...

smile

So closing.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70