Topic: Unable to install/update drush from EPEL with REMI active repository

When installing or updating a machine with drush installed from EPEL repository, with REMI repository active, there's a problem.

Drush from EPEL depends on php-phpdocumentor-reflection-docblock. REMI obsoletes this with php-phpdocumentor-reflection-docblock2. However, php-phpdocumentor-reflection-docblock2 conflicts with Drush < 8.1.10-2. The EPEL provided Drush is only 8.1.10-1 and it seems 8.1.10-2 and 8.1.10-3 are only available on Rawhide.
Additionally, the update REMI provides to php-phpdocumentor-reflection-docblock.noarch conflicts with Drush too as Drush depends on <3 yet the update on REMI to this package is 3.2.2-1

Is this a known issue? It's caused some stumbling blocks when installing updates the last few days.

I had to exclude both php-phpdocumentor-reflection-docblock and php-phpdocumentor-reflection-docblock2 from remi.repo temporarily.

Re: Unable to install/update drush from EPEL with REMI active repository

> I had to exclude both php-phpdocumentor-reflection-docblock and php-phpdocumentor-reflection-docblock2 from remi.repo temporarily.

Yes, seems the way to go for now

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Unable to install/update drush from EPEL with REMI active repository

I thinking about rebuilding latest drush for my repository... but I don't plan to rebuild all the drupal stack...

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Unable to install/update drush from EPEL with REMI active repository

drush 8.1.10-3 now in my repo, and can be installed.

BTW, seems really broken with recent PHP/Symfony versions... sad

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Unable to install/update drush from EPEL with REMI active repository

As my repository only provides a backport of the Fedora package, for some packages, better to track this upstream
=> https://bugzilla.redhat.com/show_bug.cgi?id=1532197

So version 8.1.15 is now in the repository, and seems to work.

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Unable to install/update drush from EPEL with REMI active repository

Thanks Remi! Eternally grateful for the work you do smile
I'll take a look ASAP.

Thanks again, and a late Happy New Year!