1 (edited by mjqi3s 2018-02-06 15:22:50)

Topic: installation de phpMyAdmin 4.7.x

Bonjour,

pouvez vous m'expliquer pourquoi je dois lancer :
yum --enablerepo=remi,remi-php72 install phpMyAdmin
pour qu'une version phpMyAdmin 4.7.X soit installée ?

machine avec : CentOS7.4/PHP7.2/apache 2.4/mariadb 10.2

merci

Re: installation de phpMyAdmin 4.7.x

Il n'y a aucune raison de faire ça

Il faut juste une version de PHP >= 5.6 (donc 5.6, 7.0, 7.1 ou 7.2)

Cf les instructions du Wizard (lien en haut à droite)

Ou alors, j'ai pas compris la question.

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: installation de phpMyAdmin 4.7.x

en fait si je fais simplement :
yum --enablerepo=remi-php72 install phpMyAdmin
c'est la version phpMyAdmin 4.4.15 qui est installée.

Re: installation de phpMyAdmin 4.7.x

C'est un choix.

Le dépôt "remi-php72" ne contient que la stack PHP, rien d'autre, de manière à ne pas remplacer de composant fournit dans les dépôts de base (ex phpMyAdmin), sauf bien sur php.

Le dépôt "remi" contient plein de paquets, notament phpMyAdmin, qui remplace les versions fournits par défaut dans les dépôts de base.

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: installation de phpMyAdmin 4.7.x

hum, posons la question différemment :
puisque "yum --enablerepo=remi,remi-php72 install phpMyAdmin" n'est pas justifiée
quelle serait la commande "normale" à exécuter pour installer phpMyAdmin 4.7.7 dans mon cas ?

Re: installation de phpMyAdmin 4.7.x

yum-config-manager --enable remi-php72 => activation permanente
yum --enablerepo=remi install phpMyAdmin

Ou

yum-config-manager --enable remi-php72
yum-config-manager --enable remi => + posibilité de filter avec le includepkgs
yum install phpMyAdmin

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: installation de phpMyAdmin 4.7.x

OK - grand merci.