Topic: remi repo dependency check failure when trying to install phpMyAdmin

Hello,

I have been using iUS repo for php5.6 together with remi repo for phpMyAdmin. The installation and updates run flawlessly.
Lately we are starting to test php7.2 (from iUS) and attempt to install phpMyAdmin from remi repo fails dependency check.
Don't understand why remi repo tries to install v5.4 of php-common while php72u-common is already installed.

Any help would be appreciated! Thanks!

--> Processing Conflict: php72u-common-7.2.4-1.ius.centos7.x86_64 conflicts php-common < 7.2.4-1.ius.centos7
--> Processing Conflict: php72u-gmp-7.2.4-1.ius.centos7.x86_64 conflicts php-gmp < 7.2.4-1.ius.centos7
--> Processing Conflict: php72u-json-7.2.4-1.ius.centos7.x86_64 conflicts php-json < 7.2.4-1.ius.centos7
--> Finished Dependency Resolution
Error: php72u-json conflicts with php-common-5.4.45-14.el7.remi.x86_64
Error: php72u-gmp conflicts with php-common-5.4.45-14.el7.remi.x86_64
Error: php72u-common conflicts with php-common-5.4.45-14.el7.remi.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Re: remi repo dependency check failure when trying to install phpMyAdmin

Sorry but I CAN'T support such configuration.

Don't mix repository, use php 7.2 from remi-php72 (see the Wizard).

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: remi repo dependency check failure when trying to install phpMyAdmin

As a matter of fact, we all use mixed repos - like remi packages depend on epel, php packages in ius repos works with httpd package in the other repos.
But thanks for your explanation and maintaining remi repo. It has helped me a lot with phpmyadmin with ius php56u.

Re: remi repo dependency check failure when trying to install phpMyAdmin

> php packages in ius repos works with httpd package in the other repos.

I'm not aware of such thing. mod_php in IUS is build against default system httpd (so with 2.4.x). Even in centos6 they use system httpd 2.2 (even if they provide and httpd24u package)

Using php-fpm (from any repo) allow to work with any httpd (or nginx, lighttpd...)
Read: https://developers.redhat.com/blog/2017 … tion-tips/

Remind that "remi" is upstream for other repo (Fedora, RHEL, RHSCL, centos-scl, IUS...)

And notice thant IUS brings some bad changes, which make their packages (especially fpm) incompatible with packaged web-app (e.g. phpMyAdmin, workpress, roundcubemail...)

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test