Topic: phpbuilder account chez 1&1

Bonjour,

Je viens de prendre un VPS (Cloud Dynamique) chez 1&1 parce que j'ai beaucoup trop de visiteurs pour que mon mutualisé tienne le coup... Mais je n'ai pas les compétences nécessaire pour me débrouiller seul. Après beaucoup de recherche je suis surement tombé chez mes sauveurs.

Comme prévu, je suis avec un CentOS 5 et un PHP 5.1.6... Je souhaite migrer vers le 5.3.8 mais problème je suis obligé de passer par cette étape là : http://blog.famillecollet.com/post/2010 … -php-5.3.5

Je suis désolé mais je ne comprend rien du tout, je débute tout juste. Voici ce que je suis arrivé à faire :

- Connexion SSH root@IP de mon serveur
- useradd phpbuilder
- yum install rpm-build rpmdevtools

Ensuite, il faut passer sous le compte utilisateur phpbuilder mais je n'arrive pas à me connecter à ce compte là.

Autrement, j'ai vu que ce tuto installe "deux partitions" ? Une 5.1.6 (déjà existante) et une 5.3.5 ? N'y a-t-il pas la possibilité que j'installe directement la 5.3.5 pour pouvoir passer à la 5.3.8 après ?

Merci par avance pour le temps que vous voudrez bien passer.

Re: phpbuilder account chez 1&1

Autrement, j'ai vu que ce tuto installe "deux partitions" ? Une 5.1.6 (déjà existante) et une 5.3.5 ? N'y a-t-il pas la possibilité que j'installe directement la 5.3.5 pour pouvoir passer à la 5.3.8 après ?

Si tu n'as pas besoin d'avoir les 2 versions, un simple yum update, avec le dépôt remi installé / activé te feras passer en 5.3.8.

Ce tuto, un peu ancien (mais toujours d'actualité), est vraiment spécifique à une installation ou les 2 versions sont nécessaires, d'ailleurs c'est maintenant la 5.3.8 qui est disponible en binaire (el5, x86_64) et en source.

+

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: phpbuilder account chez 1&1

Merci.

Cependant, j'ai un soucis pour installé / activé le depot remi.

J'ai trouvé ce package là : http://rpms.famillecollet.com/enterpris … php53.html

J'ai fais:

wget http://download.fedora.redhat.com/pub/e … noarch.rpm
wget http://rpms.famillecollet.com/enterpris … ease-5.rpm
rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm

Ce pack là est bien installé.

J'ai ensuite fais ça mais sans succès :


rpm -Uvh http://rpms.famillecollet.com/SRPMS/php … mi.src.rpm


Retrieving http://rpms.famillecollet.com/SRPMS/php … mi.src.rpm
   1:php                    warning: user remi does not exist - using root
warning: user remi does not exist - using root
warning: user remi does not exist - using root
warning: user remi does not exist - using root


Ai-je loupé une étape ?

Merci.

Re: phpbuilder account chez 1&1

Pourquoi ne pas simplement faire un

yum --enablerepo=remi update

?

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: phpbuilder account chez 1&1

J'ai réinitialisé mon serveur pour repartir sur bases propres.

J'ai fais :

wget http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-4.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm

yum --enablerepo=remi update

Tout à l'air de s'être bien déroulé. Je vérifie ma version de php.

# rpm -qa |grep php
psa-php5-configurator-1.5.1-cos5.build102100512.11
php-pdo-5.3.8-5.el5.remi.1
php-cli-5.3.8-5.el5.remi.1
php-mysql-5.3.8-5.el5.remi.1
php-xml-5.3.8-5.el5.remi.1
php-5.3.8-5.el5.remi.1
php-imap-5.3.8-5.el5.remi.1
php-gd-5.3.8-5.el5.remi.1
php5-ioncube-loader-3.1-07051711
php-common-5.3.8-5.el5.remi.1
php-mbstring-5.3.8-5.el5.remi.1

J'actualise ma page php où se trouve mon phpinfo(); et il me reconnait en tant que 5.1.6...

Je me suis dis que redémarrer mon serveur pouvait être une bonne idée pour que ça soit pris en compte. A l'ouverture de Parallels Smal Business Panel 10, Google Chrome m'annonce : "Le site Web a rencontré une erreur lors de l'extraction de https://212.227.28.254:8443/smb/. Cela peut être dû à une opération de maintenance ou à une configuration incorrecte."

Ai-je encore loupé une étape pour que tout soit compatible ?

Re: phpbuilder account chez 1&1

Je ne suis pas sur que "Parallels Smal Business Panel 10" soit compatible php 5.3.
De plus il faut aussi vérifier qu'une version d'ioncube compatible soit installée.

Personnellement je ne serais d'aucune aide pour ces produits propriétaires => voir avec leur support.

+

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi