Topic: Missing Dependency: php-common = 5.2.9

I am attempting to upgrade the existing PHP installation on my Centos 5.3 server but am greeted with the following message:

Error: Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package XYZ

This line is duplicate with XYZ replaced by all the other php packages. For example:

Error: Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-5.2.9-1.el5.remi.x86_64 (remi)

Any clues as to what I may be doing incorrectly?

Re: Missing Dependency: php-common = 5.2.9

Please post the full command + output.

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Missing Dependency: php-common = 5.2.9

# yum update
Loaded plugins: dellsysidplugin, dellsysidplugin2, fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * epel: fedora.tu-chemnitz.de
 * extras: [url=http://www.mirrorservice.org]www.mirrorservice.org[/url]
 * updates: [url=http://www.mirrorservice.org]www.mirrorservice.org[/url]
 * remi: rpms.famillecollet.com
 * base: [url=http://www.mirrorservice.org]www.mirrorservice.org[/url]
 * addons: [url=http://www.mirrorservice.org]www.mirrorservice.org[/url]
epel                                                                                                                                  | 2.1 kB     00:00
primary.sqlite.bz2                                                                                                                    | 2.9 MB     00:15
extras                                                                                                                                | 1.1 kB     00:00
adobe-linux-i386                                                                                                                      |  951 B     00:00
dell-omsa-specific                                                                                                                    | 2.0 kB     00:00
updates                                                                                                                               |  951 B     00:00
primary.xml.gz                                                                                                                        | 177 kB     00:01
updates                                                        343/343
dell-omsa-indep                                                                                                                       | 2.0 kB     00:00
remi                                                                                                                                  | 2.0 kB     00:00
primary.sqlite.bz2                                                                                                                    |  98 kB     00:00
base                                                                                                                                  | 1.1 kB     00:00
graphviz-stable                                                                                                                       |  951 B     00:00
addons                                                                                                                                |  951 B     00:00
169 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mysql.x86_64 0:5.1.35-1.el5.remi set to be updated
--> Processing Dependency: mysql-libs = 5.1.35-1.el5.remi for package: mysql
--> Processing Dependency: libmysqlclient_r.so.16(libmysqlclient_16)(64bit) for package: mysql
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: mysql
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: mysql
--> Processing Dependency: libmysqlclient_r.so.16()(64bit) for package: mysql
---> Package perl-File-Find-Rule.noarch 0:0.30-3.el5 set to be updated
---> Package php-xml.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-xml
---> Package perl-version.x86_64 1:0.7203-1.el5 set to be updated
---> Package libmp4v2.x86_64 0:1.5.0.1-6.el5 set to be updated
---> Package unison213.x86_64 0:2.13.16-9.el5.2 set to be updated
---> Package php.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php
---> Package libsndfile.x86_64 0:1.0.17-2.el5 set to be updated
---> Package perl-Number-Compare.noarch 0:0.01-8.el5 set to be updated
---> Package libcdio.x86_64 0:0.78.2-5.el5 set to be updated
---> Package cups.x86_64 1:1.3.7-8.el5_3.6 set to be updated
---> Package unison227.x86_64 0:2.27.57-7.el5.2 set to be updated
---> Package libcaca.x86_64 0:0.99-0.5.beta16.el5 set to be updated
---> Package perl-Error.noarch 1:0.17010-1.el5 set to be updated
---> Package libmodplug.x86_64 1:0.8.4-1.el5 set to be updated
---> Package cups-devel.i386 1:1.3.7-8.el5_3.6 set to be updated
---> Package perl-HTML-TableExtract.noarch 0:2.10-2.el5 set to be updated
---> Package id3lib.x86_64 0:3.8.3-20.el5 set to be updated
---> Package libid3tag.x86_64 0:0.15.1b-5.el5 set to be updated
---> Package gsm.x86_64 0:1.0.12-4.el5 set to be updated
--> Processing Dependency: libmysqlclient.so.15()(64bit) for package: dovecot
--> Processing Dependency: libmysqlclient.so.15()(64bit) for package: perl-DBD-MySQL
--> Processing Dependency: libmysqlclient.so.15()(64bit) for package: mysql-connector-odbc
--> Processing Dependency: libmysqlclient.so.15()(64bit) for package: libdbi-dbd-mysql
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15)(64bit) for package: dovecot
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15)(64bit) for package: perl-DBD-MySQL
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15)(64bit) for package: mysql-connector-odbc
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15)(64bit) for package: libdbi-dbd-mysql
--> Processing Dependency: libmysqlclient_r.so.15()(64bit) for package: mysql-connector-odbc
--> Processing Dependency: libmysqlclient_r.so.15()(64bit) for package: MySQL-python
--> Processing Dependency: libmysqlclient_r.so.15(libmysqlclient_15)(64bit) for package: mysql-connector-odbc
--> Processing Dependency: libmysqlclient_r.so.15(libmysqlclient_15)(64bit) for package: MySQL-python
---> Package perl-Text-Glob.noarch 0:0.08-2.el5 set to be updated
---> Package cups-libs.i386 1:1.3.7-8.el5_3.6 set to be updated
---> Package svgalib.x86_64 0:1.9.25-3.el5 set to be updated
---> Package cups-devel.x86_64 1:1.3.7-8.el5_3.6 set to be updated
---> Package perl-File-Slurp.noarch 0:9999.13-3.el5 set to be updated
---> Package perl-HTML-Template.noarch 0:2.9-1.el5.2 set to be updated
---> Package mysql-server.x86_64 0:5.1.35-1.el5.remi set to be updated
---> Package denyhosts.noarch 0:2.6-5.el5 set to be updated
---> Package php-pdo.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-pdo
--> Processing Dependency: libsqlite.so.0()(64bit) for package: php-pdo
---> Package libdvdread.x86_64 0:4.1.3-1.el5 set to be updated
---> Package iftop.x86_64 0:0.17-6.el5 set to be updated
---> Package SDL_image.x86_64 0:1.2.5-4.el5 set to be updated
---> Package php-mysql.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-mysql
---> Package perl-File-Tail.noarch 0:0.99.3-5.el5.1 set to be updated
---> Package munin.noarch 0:1.2.6-4.el5 set to be updated
---> Package cppunit.x86_64 0:1.12.0-4.el5.1 set to be updated
---> Package php-mbstring.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-mbstring
---> Package id3lib.i386 0:3.8.3-20.el5 set to be updated
---> Package taglib.x86_64 0:1.5-2.el5 set to be updated
---> Package php-pear.noarch 1:1.8.1-1.el5.remi set to be updated
---> Package php-gd.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-gd
---> Package php-cli.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-cli
---> Package libsigc++20.x86_64 0:2.0.18-1.el5 set to be updated
---> Package php-ldap.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-ldap
---> Package cups-libs.x86_64 1:1.3.7-8.el5_3.6 set to be updated
---> Package libid3tag-devel.x86_64 0:0.15.1b-5.el5 set to be updated
---> Package munin-node.noarch 0:1.2.6-4.el5 set to be updated
---> Package libdvdnav.x86_64 0:4.1.3-1.el5 set to be updated
--> Running transaction check
---> Package php-xml.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-xml
---> Package mysqlclient15.x86_64 0:5.0.67-1.el5.remi set to be updated
---> Package php.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php
---> Package mysql-libs.x86_64 0:5.1.35-1.el5.remi set to be updated
---> Package sqlite2.x86_64 0:2.8.17-2.el5.remi set to be updated
---> Package php-pdo.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-pdo
---> Package php-mysql.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-mysql
---> Package php-mbstring.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-mbstring
---> Package php-gd.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-gd
---> Package php-cli.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-cli
---> Package php-ldap.x86_64 0:5.2.9-1.el5.remi set to be updated
--> Processing Dependency: php-common = 5.2.9-1.el5.remi for package: php-ldap
--> Finished Dependency Resolution
php-xml-5.2.9-1.el5.remi.x86_64 from remi has depsolving problems
  --> Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-xml-5.2.9-1.el5.remi.x86_64 (remi)
php-cli-5.2.9-1.el5.remi.x86_64 from remi has depsolving problems
  --> Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-cli-5.2.9-1.el5.remi.x86_64 (remi)
php-5.2.9-1.el5.remi.x86_64 from remi has depsolving problems
  --> Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-5.2.9-1.el5.remi.x86_64 (remi)
php-ldap-5.2.9-1.el5.remi.x86_64 from remi has depsolving problems
  --> Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-ldap-5.2.9-1.el5.remi.x86_64 (remi)
php-gd-5.2.9-1.el5.remi.x86_64 from remi has depsolving problems
  --> Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-gd-5.2.9-1.el5.remi.x86_64 (remi)
php-pdo-5.2.9-1.el5.remi.x86_64 from remi has depsolving problems
  --> Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-pdo-5.2.9-1.el5.remi.x86_64 (remi)
php-mbstring-5.2.9-1.el5.remi.x86_64 from remi has depsolving problems
  --> Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-mbstring-5.2.9-1.el5.remi.x86_64 (remi)
php-mysql-5.2.9-1.el5.remi.x86_64 from remi has depsolving problems
  --> Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-mysql-5.2.9-1.el5.remi.x86_64 (remi)
Error: Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-pdo-5.2.9-1.el5.remi.x86_64 (remi)
Error: Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-5.2.9-1.el5.remi.x86_64 (remi)
Error: Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-mbstring-5.2.9-1.el5.remi.x86_64 (remi)
Error: Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-xml-5.2.9-1.el5.remi.x86_64 (remi)
Error: Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-mysql-5.2.9-1.el5.remi.x86_64 (remi)
Error: Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-cli-5.2.9-1.el5.remi.x86_64 (remi)
Error: Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-ldap-5.2.9-1.el5.remi.x86_64 (remi)
Error: Missing Dependency: php-common = 5.2.9-1.el5.remi is needed by package php-gd-5.2.9-1.el5.remi.x86_64 (remi)

Re: Missing Dependency: php-common = 5.2.9

Really strange... php-common is in the repo.

Can you :

yum clean all
yum list php-common

And I see : "169 packages excluded due to repository priority protections"

Can you remove protection, this is probably one of this rule which cause the issue.

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test