1 (edited by tmy 2016-04-12 09:49:00)

Topic: more-php56-php-pecl-memcached-2.2.0-7 missing depedency

Seems there's missing dependency on memcached plugin.
After installing it and running:

# scl enable rh-php56 'php -v'
PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/rh/rh-php56/root/usr/lib64/php/modules/memcached.so' - libsasl2.so.2: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.6.5 (cli) (built: Oct  5 2015 21:20:24) 
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2014 Zend Technologies
    with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2014, by Zend Technologies
    with Xdebug v2.2.7, Copyright (c) 2002-2015, by Derick Rethans

I couldn't find any package providing libsasl2.so.2.
Closest packages is cyrus-sasl-lib which provides /usr/lib64/libsasl2.so.3

Re: more-php56-php-pecl-memcached-2.2.0-7 missing depedency

Distro ? Version ? Arch ?

And "rpm -qa \*php\* | sort"

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: more-php56-php-pecl-memcached-2.2.0-7 missing depedency

I have rebuild the more-php56-php-pecl-memcached (2.2.0-9) to add the missing dependency on cyrus-sasl-lib.

But:
- in EL-6 you have libsasl2.so.2 (cyrus-sasl-lib-2.1.23-15.el6_6.2.x86_64)
- in EL-7 you have libsasl2.so.3 (cyrus-sasl-lib-2.1.26-20.el7_2.x86_64)

So, I think there is something wrong in your settings.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

4 (edited by tmy 2016-04-13 05:13:32)

Re: more-php56-php-pecl-memcached-2.2.0-7 missing depedency

Thanks for the quick fix.

I'm using CentOS 7 with x86_64.
Now that I look the softwarecollections.org it seems to list the EL6 version of the repo on top instead of EL7. IIRC I picked the top one when setting up the server.
So I probably have the wrong version of the repo for my server. At least thats my assumption as I can't currently login to the server to verify it.

Edit:
Found the documentation of the steps I did on the server and it shows I indeed installed the EL6 version of the repo.