Topic: erreur paquet quand update glpi

Bonjour,
Actuellement sur un serveur rhel6.6, j'ai GLPI d’installer (version 0.90.5). J’aimerais passer en version 9.1. Mais j'ai des erreurs de paquet, ci-dessous la sortie de la commande:

# yum --enablerepo=remi,remi-test  update glpi
Erreur : Paquet : php-pecl-apcu-4.0.11-2.el6.remi.5.5.x86_64 (remi-php55)
             Requiert : php(zend-abi) = 20121212-64
             Suppression : php-common-5.5.20-2.el6.remi.x86_64 (@remi-php55)
                 php(zend-abi) = 20121212-64
             Mis à jour par : php-common-5.6.27-0.1.RC1.el6.remi.x86_64 (remi-test)
                 php(zend-abi) = 20131226-64
             Disponible : php-common-5.4.45-11.el6.remi.x86_64 (remi)
                 php(zend-abi) = 20100525-x86-64
             Disponible : php-common-5.4.45-12.el6.remi.x86_64 (remi)
                 php(zend-abi) = 20100525-x86-64
             Disponible : php-common-5.5.38-3.el6.remi.x86_64 (remi-php55)
                 php(zend-abi) = 20121212-64
             Disponible : php-common-5.5.38-4.el6.remi.x86_64 (remi-php55)
                 php(zend-abi) = 20121212-64
             Disponible : php-common-5.6.26-0.1.RC1.el6.remi.x86_64 (remi-test)
                 php(zend-abi) = 20131226-64
Erreur : Paquet : php-ZendFramework2-Mail-2.3.3-2.el6.remi.noarch (@remi)
             Requiert : php-composer(zendframework/zend-loader) = 2.3.3
             Suppression : php-ZendFramework2-Loader-2.3.3-2.el6.remi.noarch (@remi)
                 php-composer(zendframework/zend-loader) = 2.3.3
             Rendu obsolète par : php-zendframework-zend-loader-2.5.1-4.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-loader) = 2.5.1
             Disponible : php-ZendFramework2-Loader-2.4.9-1.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-loader) = 2.4.9
             Disponible : php-ZendFramework2-Loader-2.4.10-1.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-loader) = 2.4.10
             Disponible : php-zendframework-zend-loader-2.5.1-3.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-loader) = 2.5.1
Erreur : Paquet : php-pecl-apcu-4.0.11-2.el6.remi.5.5.x86_64 (remi-php55)
             Requiert : php(api) = 20121113-64
             Suppression : php-common-5.5.20-2.el6.remi.x86_64 (@remi-php55)
                 php(api) = 20121113-64
             Mis à jour par : php-common-5.6.27-0.1.RC1.el6.remi.x86_64 (remi-test)
                 php(api) = 20131106-64
             Disponible : php-common-5.4.45-11.el6.remi.x86_64 (remi)
                 php(api) = 20100412-x86-64
             Disponible : php-common-5.4.45-12.el6.remi.x86_64 (remi)
                 php(api) = 20100412-x86-64
             Disponible : php-common-5.5.38-3.el6.remi.x86_64 (remi-php55)
                 php(api) = 20121113-64
             Disponible : php-common-5.5.38-4.el6.remi.x86_64 (remi-php55)
                 php(api) = 20121113-64
             Disponible : php-common-5.6.26-0.1.RC1.el6.remi.x86_64 (remi-test)
                 php(api) = 20131106-64
Erreur : Paquet : php-ZendFramework2-Console-2.3.3-2.el6.remi.noarch (@remi)
             Requiert : php-composer(zendframework/zend-stdlib) = 2.3.3
             Suppression : php-ZendFramework2-Stdlib-2.3.3-2.el6.remi.noarch (@remi)
                 php-composer(zendframework/zend-stdlib) = 2.3.3
             Rendu obsolète par : php-zendframework-zend-stdlib-2.7.7-1.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-stdlib) = 2.7.7
             Disponible : php-ZendFramework2-Stdlib-2.4.9-1.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-stdlib) = 2.4.9
             Disponible : php-ZendFramework2-Stdlib-2.4.10-1.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-stdlib) = 2.4.10
             Disponible : php-zendframework-zend-stdlib-2.7.6-1.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-stdlib) = 2.7.6
Erreur : Paquet : php-ZendFramework2-Code-2.3.3-2.el6.remi.noarch (@remi)
             Requiert : php-composer(zendframework/zend-eventmanager) = 2.3.3
             Suppression : php-ZendFramework2-EventManager-2.3.3-2.el6.remi.noarch (@remi)
                 php-composer(zendframework/zend-eventmanager) = 2.3.3
             Rendu obsolète par : php-zendframework-zend-eventmanager-2.6.3-1.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-eventmanager) = 2.6.3
             Disponible : php-ZendFramework2-EventManager-2.4.9-1.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-eventmanager) = 2.4.9
             Disponible : php-ZendFramework2-EventManager-2.4.10-1.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-eventmanager) = 2.4.10
             Disponible : php-zendframework-zend-eventmanager-2.6.2-1.el6.remi.noarch (remi)
                 php-composer(zendframework/zend-eventmanager) = 2.6.2
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest

pouvez-vous m'aidez. Merci d'avance.

Re: erreur paquet quand update glpi

Lire => https://blog.remirepo.net/post/2016/08/ … .6-requise

Donc il faut activer le dépôt remi-php56

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: erreur paquet quand update glpi

P.S. ajouter "includepkgs=glpi*" dans le fichier remi-test.repo pourrait suffire, et semble préférable, en effet, ce dépôt de test contient plein d'autres choses qui ne sont pas forcément souhaitées, comme par exemple les version RC de PHP et de certaines extensions. Dans tous les cas, utiliser PHP 5.6 reste conseillé.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: erreur paquet quand update glpi

J'ai toujours le même problème, j'ai recuperer le depot remi.repo depuis wget https://rpms.remirepo.net/enterprise/remi-release-6.rpm ; rpm -Uvh remi-release-6.rpm

Re: erreur paquet quand update glpi

On dirait que le probleme resemble a celui du forum: : Problème de dépendances php ?

Re: erreur paquet quand update glpi

Le même problème après quelle manip ?
J'ai donné les explications dans mes messages précédents

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: erreur paquet quand update glpi

Je parlais d'un post qui se trouve sur ce forum intituler Problème de dépendances php. Sinon j'ai sauvegarder le fichier /etc/http/conf.d/glpi.conf, puis
# yum update php
# yum remove glpi
# yum install glpi
et j'ai pus upgrader glpi.

Re: erreur paquet quand update glpi

ok

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70