Topic: Build pecl-database-mysql extension with php56-devel

This might be a very stupid question, but bear with me.

I am trying to setup an old-ass application copied from a shared hosting over to a fedora 28 VPS. The shared hosting has the following configuration according to phpinfo():

php 5.6.30
mysql Client API version 5.5.48 (whatever this means)

Initially, I tried using php7 from the VPS's default package manager, along with pecl-database-mysql from (because the app uses the legacy mysql functions), but it just throws errors about exhausting the memory available (I have even tried setting the mem limit to -1 on a 16 GB host, and it eats all that too). Then, I tried using php56-php-fpm together with php56-php-mysql but the app throws the same kind of errors.

My last hope is building the pecl-database-mysql against php56-php-devel to see if it works, but that's where I'm stuck. According to this post at My-PHP-Workstation under Working on PHP extensions I am supposed to call the module load command to switch the context to php56, but the problem is that such command is nowhere to be found and the extension's source does not provide 'a shell-specific initialization script' as to source it and be able to call the module command. Any ideas?

Re: Build pecl-database-mysql extension with php56-devel

You don't need to build the pecl extension.
The deprecated "mysql" extension is still available in PHP 5.x (removed in 7.x)
And for 7.x, the php-pecl-mysql package is available.

> it just throws errors about exhausting the memory available

This could be because of "mysqlnd" driver which use PHP memory allocator (thus restrain the memory usage under the memory_limit)

With old driver (libmysqlclient), your app can consumme all the server memory, without restriction (but this is obviously bad).
I only provides the mysql extension for the old driver (php-mysql package) for PHP 5.4.


BTW, your legacy app need to be fixed.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test