Topic: php 7.3.7 with php73-php-oci8 fails

php -v
PHP Warning:  PHP Startup: Unable to load dynamic library 'oci8' (tried: /opt/remi/php73/root/usr/lib64/php/modules/oci8 (/opt/remi/php73/root/usr/lib64/php/modules/oci8: cannot open shared object file: No such file or directory), /opt/remi/php73/root/usr/lib64/php/modules/oci8.so (libclntsh.so.19.1: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'pdo_oci' (tried: /opt/remi/php73/root/usr/lib64/php/modules/pdo_oci (/opt/remi/php73/root/usr/lib64/php/modules/pdo_oci: cannot open shared object file: No such file or directory), /opt/remi/php73/root/usr/lib64/php/modules/pdo_oci.so (libclntsh.so.19.1: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP 7.3.7 (cli) (built: Jul  2 2019 10:53:48) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.7, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.7, Copyright (c) 1999-2018, by Zend Technologies


works with php 7.3.6

Re: php 7.3.7 with php73-php-oci8 fails

New version need Oracle Client 19.3

https://github.com/remicollet/remirepo/issues/120

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php 7.3.7 with php73-php-oci8 fails

ah, thanks.

4 (edited by rosemary 2019-07-04 01:22:07)

Re: php 7.3.7 with php73-php-oci8 fails

It needs Oracle Client 19.3.
geometry dash