Topic: php-pear in centos 8

I am testing out CentOS 8.  I believe I followed the instructions on https://rpms.remirepo.net/wizard, but when I run "yum install php-pear", I get this:

-------
Error:
Problem: cannot install the best candidate for the job
  - nothing provides php-composer(fedora/autoloader) needed by php-pear-1:1.10.9-3.el8.remi.noarch
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
-------

Is there something else I need to do?

Thanks,
Ryan

Re: php-pear in centos 8

This one should be in EPEL, but is not yet available.

As explained on https://blog.remirepo.net/post/2019/09/ … repository

Until EPEL is fully populated, you need to enable "remi" repository

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php-pear in centos 8

BTW, I add the php-fedora-autoloader package in the modular repo.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php-pear in centos 8

For my curiosity, why do you need the php-pear package ?

Most pear packages are now deprecated
and the pecl command is not needed when most of the extensions are available as RPM

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: php-pear in centos 8

That worked, thanks for moving it.  There are 3 extensions that I was using it for:

- from pear, Console_Getopt (https://pear.php.net/package/Console_Getopt)

- from pecl, v8js (https://pecl.php.net/package/v8js) - I ended up compiling/installing this outside of pecl.  This was my main reason for trying CentOS 8, as I couldn't get the latest v8 to compile in CentOS 7 without installing a newer version of gcc, and I wasn't sure what side effects that would have.

- I don't need pecl for this, but I also use php_excel (https://github.com/iliaal/php_excel).

Thanks again for your help.

Ryan

Re: php-pear in centos 8

Thanks.

Indeed v8 and v8js are 2 extensions I forgive trying to build...
Just a nightmare (have work on Fedora in the past... but no more today....)

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test