Topic: Problem: try to install php 7.3 on Centos 6

Hello,

I am running Centos 6 with PHP 5.6. I would like to install additional version of PHP - 7.3.

I have some problem with package php-twig and I don't know how to fix it.

Please help smile

yum --enablerepo=remi-php73 install php

---> Package php-pdo-dblib.i686 0:7.3.13-1.el6.remi will be obsoleting
---> Package php-xmlrpc.i686 0:5.6.37-1.el6.remi will be updated
---> Package php-xmlrpc.i686 0:7.3.13-1.el6.remi will be an update
--> Finished Dependency Resolution
Error: Package: php-twig-1.35.4-1.el6.remi.5.6.i686 (@remi-php56)
           Requires: php(zend-abi) = 20131226-32
           Removing: php-common-5.6.37-1.el6.remi.i686 (@remi-php56)
               php(zend-abi) = 20131226-32
           Updated By: php-common-7.3.13-1.el6.remi.i686 (remi-php73)
               php(zend-abi) = 20180731-32
           Available: php-common-5.3.3-49.el6.i686 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-50.el6_10.i686 (updates)
               php(zend-abi) = 20090626
           Available: php-common-7.3.12-1.el6.remi.i686 (remi-php73)
               php(zend-abi) = 20180731-32
Error: Package: php-twig-1.35.4-1.el6.remi.5.6.i686 (@remi-php56)
           Requires: php(api) = 20131106-32
           Removing: php-common-5.6.37-1.el6.remi.i686 (@remi-php56)
               php(api) = 20131106-32
           Updated By: php-common-7.3.13-1.el6.remi.i686 (remi-php73)
               php(api) = 20180731-32
           Available: php-common-5.3.3-49.el6.i686 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-50.el6_10.i686 (updates)
               php(api) = 20090626
           Available: php-common-7.3.12-1.el6.remi.i686 (remi-php73)
               php(api) = 20180731-32
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Re: Problem: try to install php 7.3 on Centos 6

Remove php-twig before the update, of enable "remi" which now have twig 1.42 (noarch), but without the ext (which is 5.x only)

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

3 (edited by 8585 2020-01-01 00:53:34)

Re: Problem: try to install php 7.3 on Centos 6

Thank You. It works.

But the php 5.6 has been overwritten. I have tried to install additional php56:

yum install php56

but this package is not avalible. I would like just to have second version of php to run older website.

How can I do it?

Thank You

Re: Problem: try to install php 7.3 on Centos 6

To install multiple versions, you can follow the wizard instructions (top / right link on this page)

Also read: https://developers.redhat.com/blog/2017 … tion-tips/

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test