Topic: Install phpmyadmin with php 7.4

Hi,

I have installed php 7.4 as the only version on a RHEL8 server following the wizard and I run in a couple of problems when installing phpmyadmin.
phpMyAdmin-5.0.2-3.el8.remi.noarch.rpm has php-zip as a requirement but it seems there is no php-zip package for php 7.4 anymore.
It tries to install php-pecl-zip-1.15.3-1 which conflicts with php-common-7.4.10-1.el8.remi.x86_64.

Last metadata expiration check: 0:28:27 ago on Mon 28 Sep 2020 04:11:30 PM CEST.
Error:
Problem: package phpMyAdmin-5.0.2-3.el8.remi.noarch requires php-zip, but none of the providers can be installed
  - package php-pecl-zip-1.15.3-1.module+el8.1.0+3186+20164e6f.x86_64 requires php(api) = 20170718-64, but none of the providers can be installed
  - package php-pecl-zip-1.15.3-1.module+el8.1.0+3186+20164e6f.x86_64 requires php(zend-abi) = 20170718-64, but none of the providers can be installed
  - package php-pecl-zip-1.15.3-1.module+el8+2561+1aca3413.x86_64 requires php(api) = 20170718-64, but none of the providers can be installed
  - package php-pecl-zip-1.15.3-1.module+el8+2561+1aca3413.x86_64 requires php(zend-abi) = 20170718-64, but none of the providers can be installed
  - cannot install both php-common-7.2.11-1.module+el8+2561+1aca3413.x86_64 and php-common-7.4.10-1.el8.remi.x86_64
  - cannot install both php-common-7.2.11-2.module+el8.1.0+3202+af5476b9.x86_64 and php-common-7.4.10-1.el8.remi.x86_64
  - cannot install both php-common-7.2.11-4.module+el8.1.0+4555+f5cb8e18.x86_64 and php-common-7.4.10-1.el8.remi.x86_64
  - cannot install both php-common-7.2.24-1.module+el8.2.0+4601+7c76a223.x86_64 and php-common-7.4.10-1.el8.remi.x86_64
  - package php-sodium-7.4.10-1.el8.remi.x86_64 requires php-common(x86-64) = 7.4.10-1.el8.remi, but none of the providers can be installed
  - problem with installed package php-sodium-7.4.10-1.el8.remi.x86_64
  - package php-sodium-7.2.4-2.fc28.x86_64 requires php-common(x86-64) = 7.2.4-2.fc28, but none of the providers can be installed
  - cannot install the best candidate for the job
  - package php-common-7.2.4-2.fc28.x86_64 is filtered out by modular filtering
  - package php-pecl-zip-1.15.2-3.fc28.x86_64 is filtered out by modular filtering
  - package php-pecl-zip-1.15.4-1.module+el8.1.0+3189+a1bff096.x86_64 is filtered out by modular filtering
  - package php-common-7.2.32-1.el8.remi.x86_64 is filtered out by modular filtering
  - package php-common-7.2.33-1.el8.remi.x86_64 is filtered out by modular filtering
  - package php-common-7.4.10-1.el8.remi.x86_64 is filtered out by modular filtering
  - package php-pecl-zip-1.18.2-1.el8.remi.7.2.x86_64 is filtered out by modular filtering
  - package php-pecl-zip-1.18.2-1.el8.remi.7.3.x86_64 is filtered out by modular filtering
  - package php-pecl-zip-1.18.2-1.el8.remi.7.4.x86_64 is filtered out by modular filtering
  - package php-pecl-zip-1.19.0-1.el8.remi.7.2.x86_64 is filtered out by modular filtering
  - package php-pecl-zip-1.19.0-1.el8.remi.7.3.x86_64 is filtered out by modular filtering
  - package php-pecl-zip-1.19.0-1.el8.remi.7.4.x86_64 is filtered out by modular filtering
  - package php-pecl-zip-1.19.0-6.el8.remi.8.0.x86_64 is filtered out by modular filtering
  - package php-pecl-zip-1.19.0-7.el8.remi.8.0.x86_64 is filtered out by modular filtering

Is there a way to install phpmyadmin with php 7.4 ?

Thanks for your work.
zpel

Re: Install phpmyadmin with php 7.4

Version exists

- package php-pecl-zip-1.19.0-1.el8.remi.7.4.x86_64 is filtered out by modular filtering

Looks like the proper stream is not enable.

Please: 

# dnf repolist
# dnf module list php

P.S. reminder, for a proper configuration, follow the wizard instructions (top right link on all pages)

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Install phpmyadmin with php 7.4

- package php-pecl-zip-1.15.2-3.fc28.x86_64 is filtered out by modular filtering

This is very strange, F28 packages should never be there...

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Install phpmyadmin with php 7.4

Hi,

The repo modular was missing.
I have re-done :
dnf module reset php
dnf module install php:remi-7.4

and the repo was redeployed.
As I used geerlingguy's Ansible roles to install, it may be the root cause of my problem.

As for Fedora repos, it seems to be deployed with GCP's image, I found some forums talking about support for some perl module.

I'm sorry for bothering you sad
Thanks a lot

Re: Install phpmyadmin with php 7.4

smile

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test