Topic: composer-2.0.2-1.el7.remi.noarch

OS:  Centos 7.8
Using PHP 7.3 from REMI Repos

Running update generates the following error:

Error: Package: composer-2.0.2-1.el7.remi.noarch (remi)
           Requires: php-react-promise >= 2.7
           Available: php-react-promise-2.5.0-1.el7.noarch (epel)
               php-react-promise = 2.5.0-1.el7

Is there a repo that provides php-react-promise other than (EPEL)?

Thank You.

Re: composer-2.0.2-1.el7.remi.noarch

Thanks for the report

Will check ASAP

Desktop: Fedora 33 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: composer-2.0.2-1.el7.remi.noarch

php-react-promise 2.8.0 is in "remi", same place than composer so should be found by yum...

See https://rpms.remirepo.net/enterprise/7/ … omise.html

Please post full yum output.

Desktop: Fedora 33 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: composer-2.0.2-1.el7.remi.noarch

I think I am the error on this one.  Thank you for your response.

This is believed to have been caused by some legacy configurations to .repo files (been using your REPOS for a LONG time).  I was excluding packages from certain repo configuration files (I have 15 different remi repo files).  I was able to get the remi version of php-react-promise 2.8 installed.

Thank You.

Re: composer-2.0.2-1.el7.remi.noarch

smile

Desktop: Fedora 33 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test