Topic: Problème installation remi8.1 sur RHEL 8.8

Bonjour,
je rencontre un problème lors de l'installation des paquets remi 8.1 sur une distribution RHEL 8.8.
le gestionnaire de paquet m'indique qu'il lui faut la redhat-release >= 8.9 pour pouvoir s'installer.
Les serveurs étant en production, mon client ne peut pas me mettre à disposition la version RHEL 8.9 tant qu'elle n'a pas été validée chez eux. Même s'il s'agit d'une version "mineure" de la distribution.
Y a-t-il possibilité de forcer les paquets REMI à rester sur le RHEL 8.8?
cordialement

Re: Problème installation remi8.1 sur RHEL 8.8

Please read https://blog.remirepo.net/pages/English-FAQ#deps

=> "older versions are not supported"

You can try using https://rpms.remirepo.net/enterprise/re … se-8.8.rpm

BTW this won't be supported, may work, or not.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Problème installation remi8.1 sur RHEL 8.8

Pardon, je me suis mal exprimé, je souhaite installer PHP8.1.
J'ai installé les dépôts remi-release 8.8 et j'ai le problème indiqué dans mon message précédent.
La version RHEL 8.9 semble avoir été publiée en novembre dernier. La version 8.8 ne semble donc pas encore obsolète.
cordialement

Re: Problème installation remi8.1 sur RHEL 8.8

Sans la sortie complète de la commande qui échoue difficile d'aider

Je pense que c'est uniquement la mise à jour de "remi-release" qui est bloquée (ce qui est normal et voulu)
donc --skip-broken ou --exclude remi-release

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Problème installation remi8.1 sur RHEL 8.8

> La version RHEL 8.9 semble avoir été publiée en novembre dernier. La version 8.8 ne semble donc pas encore obsolète.

La version "8.8 EUS" est effectivement maintenue jusqu'en mai 2025
(si l'accès est disponible et activé, je ne sais plus cela fait parti de la souscription standard)
https://access.redhat.com/articles/rhel-eus

D'ailleurs les clones (Alma, Rocky) ne fournissent que la dernière (donc 8.9)

Et maintenir mon dépôt pour les versions EUS n'est pas prévue, ni possible avec mes ressources actuelles (temps, machines, espace...)

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: Problème installation remi8.1 sur RHEL 8.8

Je n'avais pas vu les réponses, mais c'est effectivement passé en excluant le paquet remi-release.
Je n'ai plus le message exact car je n'ai actuellement plus accès au serveur, mais il était de cette teneur:

Error:
Problem: package remi-release-8.9-3.el8.remi.noarch requires (redhat-release >= 8.9 or centos-stream-release >= 8), but none of the providers can be installed
  - cannot install the best update candidate for package remi-release-8.6-1.el8.remi.noarch
  - package redhat-release-8.9-0.1.el8.x86_64 is filtered out by exclude filtering
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Il semble cependant y avoir un changement de comportement sur ce point car il y a quelques mois encore (à la louche moins d'un an), cela ne posait pas de problème qu'on ne soit pas en dernière release RHEL.
Quoi qu'il en soit, j'ai pu effectuer l'installation.
Merci pour les informations.