1 (edited by emilemecio 2009-09-09 12:45:31)

Topic: Migrer de php 5.1 vers 5.2

Bonjour / Hello,

J'ai un serveur dédié chez 1&1 qui est en php 5.1.x et je voudrais migrer le php vers un php 5.2.x, j'ai bien trouvé des rpm mais je n'arrive pas a les utiliser ... sauriez vous me donner les quelques commande a taper via ssh pour faire cette migration.

J'avais bien trouvé un RPM mais au final je me suis retrouvé avec un php 5.3.x ce qui est pas top quand on cherche un 5.2 big_smile

Merci de votre aide par avance.
EM

PS j'ai essayé ceci trouvé au cours de nombreuses recherche google :

wget http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-3.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm

MAIS HELAS le wget me fait un php 5.3.x comment avoir le php 5.2 qui n'est pas le dernier du dépôt ?

Re: Migrer de php 5.1 vers 5.2

Voir :
http://forums.famillecollet.com/viewtop … d=189#p189
http://forums.famillecollet.com/viewtop … d=174#p174

+

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

3 (edited by emilemecio 2009-09-09 15:11:54)

Re: Migrer de php 5.1 vers 5.2

Merci Remi ca commence bien mais ca finit mal :-s

En fait quand je lance la commande appropriée pour exclure php 5.3 il me fait une :

"Error Summary" au moment du file /usr/share/mysql/  [......]

je ne comprends pas vraiment ce qui cloche ? hmm

Il y a des conflits avec le package  mysql-5.0.45-7 apparement.

Re: Migrer de php 5.1 vers 5.2

C'est pas la mise à jour de PHP le problème mais celle de mysql.

1/ soit tu veux mettre à jour MySQL 5.1.38

yum --enablerepo=remi update mysql\*

2/ soit tu veux garder le vieux mysql 5.0.45

yum --enablerepo=remi-test install mysqlclient16

+

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

5 (edited by emilemecio 2009-09-09 15:25:09)

Re: Migrer de php 5.1 vers 5.2

ce que je comprend pas c'est que tout s'enchaine quand je fais

yum --enablerepo=remi --exlude=php*5.3* install php

il lance bien la mise a jour de php 5.1 vers 5.2 après je fais

y      (pour valider)

et la le truc se lance tt seul dans me mysql je fais mon

service httpd restart

et je suis toujours en Php 5.1

Je suis pas très clair mais je suis sur ce serveur depuis ce matin et je commence surement a fatiguer ... en espérant pas te déranger de trop avec mes questions certainement très bête !



EDIT

Pour info voila ma manip :

[root@ bin]# yum --enablerepo=remi --exclude=php*5.3* install php
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel: mirror.fraunhofer.de
 * remi: rpms.famillecollet.com
Excluding Packages in global exclude list
Finished
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: php = 5.1.6-23.2.el5_3 for package: php-devel
---> Package php.x86_64 0:5.2.10-1.el5.remi set to be updated
--> Processing Dependency: php-cli = 5.2.10-1.el5.remi for package: php
--> Processing Dependency: php-common = 5.2.10-1.el5.remi for package: php
--> Running transaction check
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-pdo
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-mbstring
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-xml
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-mysql
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-gd
--> Processing Dependency: php-common = 5.1.6-23.2.el5_3 for package: php-imap
---> Package php-cli.x86_64 0:5.2.10-1.el5.remi set to be updated
---> Package php-common.x86_64 0:5.2.10-1.el5.remi set to be updated
---> Package php-devel.x86_64 0:5.2.10-1.el5.remi set to be updated
--> Running transaction check
---> Package php-mbstring.x86_64 0:5.2.10-1.el5.remi set to be updated
---> Package php-pdo.x86_64 0:5.2.10-1.el5.remi set to be updated
--> Processing Dependency: libsqlite.so.0()(64bit) for package: php-pdo
---> Package php-gd.x86_64 0:5.2.10-1.el5.remi set to be updated
--> Processing Dependency: libt1.so.5()(64bit) for package: php-gd
---> Package php-imap.x86_64 0:5.2.10-1.el5.remi set to be updated
---> Package php-mysql.x86_64 0:5.2.10-1.el5.remi set to be updated
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: php-mysql
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: php-mysql
---> Package php-xml.x86_64 0:5.2.10-1.el5.remi set to be updated
--> Running transaction check
---> Package t1lib.x86_64 0:5.1.1-7.el5 set to be updated
--> Processing Dependency: libXaw.so.7()(64bit) for package: t1lib
---> Package sqlite2.x86_64 0:2.8.17-2.el5.remi set to be updated
---> Package mysql-libs.x86_64 0:5.1.38-1.el5.remi set to be updated
--> Running transaction check
---> Package libXaw.x86_64 0:1.0.2-8.1 set to be updated
--> Processing Dependency: libXmu.so.6()(64bit) for package: libXaw
--> Running transaction check
---> Package libXmu.x86_64 0:1.0.2-5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================
 Package                                 Arch                              Version                                        Repository                       Size
================================================================================================================================================================
Updating:
 php                                     x86_64                            5.2.10-1.el5.remi                              remi                            1.3 M
 php-cli                                 x86_64                            5.2.10-1.el5.remi                              remi                            2.4 M
 php-common                              x86_64                            5.2.10-1.el5.remi                              remi                            269 k
 php-devel                               x86_64                            5.2.10-1.el5.remi                              remi                            582 k
 php-gd                                  x86_64                            5.2.10-1.el5.remi                              remi                            126 k
 php-imap                                x86_64                            5.2.10-1.el5.remi                              remi                             55 k
 php-mbstring                            x86_64                            5.2.10-1.el5.remi                              remi                            1.1 M
 php-mysql                               x86_64                            5.2.10-1.el5.remi                              remi                             88 k
 php-pdo                                 x86_64                            5.2.10-1.el5.remi                              remi                             95 k
 php-xml                                 x86_64                            5.2.10-1.el5.remi                              remi                            121 k
Installing for dependencies:
 libXaw                                  x86_64                            1.0.2-8.1                                      base                            329 k
 libXmu                                  x86_64                            1.0.2-5                                        base                             63 k
 mysql-libs                              x86_64                            5.1.38-1.el5.remi                              remi                            2.1 M
 sqlite2                                 x86_64                            2.8.17-2.el5.remi                              remi                            166 k
 t1lib                                   x86_64                            5.1.1-7.el5                                    epel                            208 k

Transaction Summary
================================================================================================================================================================
Install      5 Package(s)
Update      10 Package(s)
Remove       0 Package(s)

Total size: 8.9 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /etc/my.cnf from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/charsets/Index.xml from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/charsets/README from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/charsets/ascii.xml from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/charsets/cp1250.xml from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/czech/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/danish/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/dutch/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/english/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/estonian/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/french/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/german/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/greek/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/italian/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/japanese/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/korean/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/polish/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/russian/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/serbian/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/slovak/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/spanish/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/swedish/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64
  file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-libs-5.1.38-1.el5.remi.x86_64 conflicts with file from package mysql-5.0.45-7.el5.x86_64

Error Summary
-------------

# service httpd restart
# php -v
# PHP 5.1

6 (edited by emilemecio 2009-09-09 15:30:11)

Re: Migrer de php 5.1 vers 5.2

MERCIIII REMI je suis a l'ouest !!!!

en fait il fallait que je tape le yum de non prise en compte de mysql avant !!!


MERCI MERCI pour la réactivité et les explications claires quand on les lis à l'endroit lol (Honte à moi big_smile)

Re: Migrer de php 5.1 vers 5.2

Bonjour Remi,

Je suis actuellement dans la même configuration qu'"emilemecio" à la différence prêt c'est que je n'y connais pas grand chose en PHP, mais j'ai suffisamment de connaissance lorqu'on me guide.

Mon problème est que je souhaite migrer de version de base de données [Version de la base de données:     5.1.49-3-log] chez OVH et je souhaiterai migrer sous 5.2.
Est ce que vous pourriez m'aider svp
Merci bcp!
Dauphin