Topic: Can't update phpmyadmin 4.7.3 -> 4.8.1

Hello.

I have problem with update phpmyadmin to 4.8.1 from remi repo.

root@caprica ~# cat /etc/centos-release
CentOS Linux release 7.5.1804 (Core)

root@caprica ~# yum repolist
Loaded plugins: changelog, fastestmirror
Loading mirror speeds from cached hostfile
[...]
repo id                                                                            repo name                                                                                                            status
base/7/x86_64                                                                      CentOS-7 - Base                                                                                                       9909+2
elrepo                                                                             ELRepo.org Community Enterprise Linux Repository - el7                                                                   249
epel/x86_64                                                                        Extra Packages for Enterprise Linux 7 - x86_64                                                                       12575+2
extras/7/x86_64                                                                    CentOS-7 - Extras                                                                                                        305
lynis                                                                              CISOfy Software - Lynis package                                                                                           31
mariadb                                                                            MariaDB                                                                                                                   51
ocsinventory/x86_64                                                                OCS Inventory NG repository for Enterprise Linux 7 - x86_64                                                               18
remi-php71                                                                         Remi's PHP 7.1 RPM repository for Enterprise Linux 7 - x86_64                                                            388
remi-safe                                                                          Safe Remi's RPM repository for Enterprise Linux 7 - x86_64                                                              2671
updates/7/x86_64                                                                   CentOS-7 - Updates                                                                                                     630+2
zabbix/x86_64                                                                      Zabbix Official Repository - x86_64                                                                                      183
zabbix-non-supported/x86_64                                                        Zabbix Official Repository non-supported - x86_64                                                                          4
repolist: 27014


root@caprica ~# yum list phpmyadmin
[...]
Installed Packages
phpMyAdmin.noarch                                                                                    4.7.3-1.el7.remi                                                         @remi

root@caprica ~# yum --enablerepo=remi update phpmyadmin
Loaded plugins: changelog, fastestmirror
Loading mirror speeds from cached hostfile
[...]
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin.noarch 0:4.7.3-1.el7.remi will be updated
---> Package phpMyAdmin.noarch 0:4.8.1-1.el7.remi will be an update
--> Processing Dependency: php-symfony-expression-language < 4 for package: phpMyAdmin-4.8.1-1.el7.remi.noarch
--> Processing Dependency: php-twig-extensions >= 1.5.1 for package: phpMyAdmin-4.8.1-1.el7.remi.noarch
--> Processing Dependency: php-twig >= 1.34 for package: phpMyAdmin-4.8.1-1.el7.remi.noarch
--> Processing Dependency: php-symfony-polyfill >= 1.7.0-2 for package: phpMyAdmin-4.8.1-1.el7.remi.noarch
--> Processing Dependency: php-psr-container >= 1.0 for package: phpMyAdmin-4.8.1-1.el7.remi.noarch
--> Processing Dependency: php-phpmyadmin-motranslator >= 4.0 for package: phpMyAdmin-4.8.1-1.el7.remi.noarch
--> Running transaction check
---> Package php-phpmyadmin-motranslator.noarch 0:3.4-1.el7 will be updated
--> Processing Dependency: php-composer(phpmyadmin/motranslator) < 4 for package: php-phpmyadmin-sql-parser-4.2.4-1.el7.noarch
---> Package php-phpmyadmin-motranslator.noarch 0:4.0-1.el7.remi will be an update
---> Package php-psr-container.noarch 0:1.0.0-1.el7.remi will be installed
---> Package php-symfony-expression-language.noarch 0:2.8.41-1.el7.remi will be installed
--> Processing Dependency: php-symfony-common = 2.8.41-1.el7.remi for package: php-symfony-expression-language-2.8.41-1.el7.remi.noarch
---> Package php-symfony-polyfill.noarch 0:1.8.0-1.el7.remi will be installed
--> Processing Dependency: php-composer(paragonie/random_compat) < 3.0 for package: php-symfony-polyfill-1.8.0-1.el7.remi.noarch
--> Processing Dependency: php-composer(ircmaxell/password-compat) < 2.0 for package: php-symfony-polyfill-1.8.0-1.el7.remi.noarch
--> Processing Dependency: php-composer(paragonie/random_compat) >= 1.0 for package: php-symfony-polyfill-1.8.0-1.el7.remi.noarch
--> Processing Dependency: php-composer(ircmaxell/password-compat) >= 1.0 for package: php-symfony-polyfill-1.8.0-1.el7.remi.noarch
--> Processing Dependency: php-intl for package: php-symfony-polyfill-1.8.0-1.el7.remi.noarch
---> Package php-twig.noarch 0:1.35.3-1.el7.remi.7.1 will be installed
---> Package php-twig-extensions.noarch 0:1.5.1-1.el7.remi will be installed
--> Processing Dependency: php-composer(symfony/translation) < 4.0 for package: php-twig-extensions-1.5.1-1.el7.remi.noarch
--> Processing Dependency: php-composer(symfony/translation) >= 2.7.1 for package: php-twig-extensions-1.5.1-1.el7.remi.noarch
--> Running transaction check
---> Package php-intl.x86_64 0:7.1.18-1.el7.remi will be installed
---> Package php-paragonie-random-compat.noarch 0:2.0.12-1.el7.remi will be installed
---> Package php-password-compat.noarch 0:1.0.4-1.el7.remi will be installed
---> Package php-phpmyadmin-sql-parser.noarch 0:4.2.4-1.el7 will be updated
---> Package php-phpmyadmin-sql-parser.noarch 0:4.2.4-3.el7.remi will be an update
---> Package php-symfony-common.noarch 0:2.8.41-1.el7.remi will be installed
--> Processing Dependency: php-symfony-class-loader = 2.8.41-1.el7.remi for package: php-symfony-common-2.8.41-1.el7.remi.noarch
---> Package php-symfony3-translation.noarch 0:3.4.11-1.el7.remi will be installed
--> Processing Dependency: php-symfony3-common = 3.4.11-1.el7.remi for package: php-symfony3-translation-3.4.11-1.el7.remi.noarch
--> Running transaction check
---> Package php-symfony-class-loader.noarch 0:2.8.41-1.el7.remi will be installed
---> Package php-symfony3-common.noarch 0:3.2.13-1.el7.remi will be updated
--> Processing Dependency: php-symfony3-common = 3.2.13-1.el7.remi for package: php-symfony3-cache-3.2.13-1.el7.remi.noarch
---> Package php-symfony3-common.noarch 0:3.4.11-1.el7.remi will be an update
--> Processing Dependency: composer for package: php-symfony3-common-3.4.11-1.el7.remi.noarch
--> Running transaction check
---> Package composer.noarch 0:1.6.5-1.el7.remi will be installed
--> Processing Dependency: php-composer(seld/phar-utils) < 2 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-composer(seld/jsonlint) < 2 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-composer(seld/cli-prompt) < 2 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-composer(composer/spdx-licenses) < 2 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-composer(composer/semver) < 2 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-composer(composer/ca-bundle) < 2 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-seld-phar-utils >= 1.0.1 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-seld-cli-prompt >= 1.0.0-3 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-composer(seld/phar-utils) >= 1.0 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-composer(seld/jsonlint) >= 1.4 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-composer(seld/cli-prompt) >= 1.0 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-composer(composer/spdx-licenses) >= 1.2 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-composer(composer/semver) >= 1.0 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-composer(composer/ca-bundle) >= 1.0 for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-symfony-process for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-symfony-finder for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-symfony-filesystem for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-symfony-console for package: composer-1.6.5-1.el7.remi.noarch
--> Processing Dependency: php-justinrainbow-json-schema5 for package: composer-1.6.5-1.el7.remi.noarch
---> Package php-symfony3-cache.noarch 0:3.2.13-1.el7.remi will be updated
--> Processing Dependency: php-composer(symfony/cache) = 3.2.13 for package: php-symfony3-expression-language-3.2.13-1.el7.remi.noarch
---> Package php-symfony3-cache.noarch 0:3.4.11-1.el7.remi will be an update
--> Processing Dependency: php-composer(psr/simple-cache) < 2.0 for package: php-symfony3-cache-3.4.11-1.el7.remi.noarch
--> Processing Dependency: php-composer(psr/simple-cache) >= 1.0 for package: php-symfony3-cache-3.4.11-1.el7.remi.noarch
--> Running transaction check
---> Package php-composer-ca-bundle.noarch 0:1.1.1-1.el7.remi will be installed
---> Package php-composer-semver.noarch 0:1.4.2-2.el7.remi will be installed
---> Package php-composer-spdx-licenses.noarch 0:1.4.0-1.el7.remi will be installed
---> Package php-jsonlint.noarch 0:1.7.1-1.el7.remi will be installed
---> Package php-justinrainbow-json-schema5.noarch 0:5.2.7-1.el7.remi will be installed
---> Package php-psr-simple-cache.noarch 0:1.0.1-1.el7.remi will be installed
---> Package php-seld-cli-prompt.noarch 0:1.0.3-1.el7.remi will be installed
---> Package php-seld-phar-utils.noarch 0:1.0.1-2.el7.remi will be installed
---> Package php-symfony-console.noarch 0:2.8.41-1.el7.remi will be installed
--> Processing Dependency: php-composer(symfony/event-dispatcher) = 2.8.41 for package: php-symfony-console-2.8.41-1.el7.remi.noarch
---> Package php-symfony-filesystem.noarch 0:2.8.41-1.el7.remi will be installed
---> Package php-symfony-finder.noarch 0:2.8.41-1.el7.remi will be installed
---> Package php-symfony-process.noarch 0:2.8.41-1.el7.remi will be installed
---> Package php-symfony3-expression-language.noarch 0:3.2.13-1.el7.remi will be updated
---> Package php-symfony3-expression-language.noarch 0:3.4.11-1.el7.remi will be an update
--> Running transaction check
---> Package php-symfony-event-dispatcher.noarch 0:2.8.41-1.el7.remi will be installed
--> Processing Dependency: php-composer(symfony/http-kernel) = 2.8.41 for package: php-symfony-event-dispatcher-2.8.41-1.el7.remi.noarch
--> Processing Dependency: php-composer(symfony/dependency-injection) = 2.8.41 for package: php-symfony-event-dispatcher-2.8.41-1.el7.remi.noarch
--> Running transaction check
---> Package php-symfony-dependency-injection.noarch 0:2.8.41-1.el7.remi will be installed
--> Processing Dependency: php-composer(symfony/yaml) = 2.8.41 for package: php-symfony-dependency-injection-2.8.41-1.el7.remi.noarch
--> Processing Dependency: php-composer(symfony/config) = 2.8.41 for package: php-symfony-dependency-injection-2.8.41-1.el7.remi.noarch
---> Package php-symfony-event-dispatcher.noarch 0:2.8.41-1.el7.remi will be installed
--> Processing Dependency: php-composer(symfony/http-kernel) = 2.8.41 for package: php-symfony-event-dispatcher-2.8.41-1.el7.remi.noarch
--> Running transaction check
---> Package php-symfony-config.noarch 0:2.8.41-1.el7.remi will be installed
---> Package php-symfony-event-dispatcher.noarch 0:2.8.41-1.el7.remi will be installed
--> Processing Dependency: php-composer(symfony/http-kernel) = 2.8.41 for package: php-symfony-event-dispatcher-2.8.41-1.el7.remi.noarch
---> Package php-symfony-yaml.noarch 0:2.8.41-1.el7.remi will be installed
--> Finished Dependency Resolution
Error: Package: php-symfony-event-dispatcher-2.8.41-1.el7.remi.noarch (remi)
           Requires: php-composer(symfony/http-kernel) = 2.8.41
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
root@caprica ~#

What should I do to make it work? smile

Regards.

Re: Can't update phpmyadmin 4.7.3 -> 4.8.1

> Error: Package: php-symfony-event-dispatcher-2.8.41-1.el7.remi.noarch (remi)
>           Requires: php-composer(symfony/http-kernel) = 2.8.41

Strange, the package is there... https://rpms.remirepo.net/enterprise/7/ … ernel.html

$ rpm -qp --provides enterprise/7/remi/x86_64/php-symfony-http-kernel-2.8.41-1.el7.remi.noarch.rpm 
php-composer(symfony/http-kernel) = 2.8.41
Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Can't update phpmyadmin 4.7.3 -> 4.8.1

Test:

# LANG=C yum --enablerepo=remi install phpMyAdmin
...
Dependencies Resolved

=======================================================================================================
 Package                               Arch        Version                       Repository       Size
=======================================================================================================
Installing:
 phpMyAdmin                            noarch      4.8.1-1.el7.remi              remi            5.1 M
Installing for dependencies:
 composer                              noarch      1.6.5-1.el7.remi              remi            381 k
 php-PsrLog                            noarch      1.0.2-2.el7.remi              remi             11 k
 php-bcmath                            x86_64      7.2.6-1.el7.remi              remi-php72       69 k
 php-composer-ca-bundle                noarch      1.1.1-1.el7.remi              remi             12 k
 php-composer-semver                   noarch      1.4.2-2.el7.remi              remi             16 k
 php-composer-spdx-licenses            noarch      1.4.0-1.el7.remi              remi             16 k
 php-gd                                x86_64      7.2.6-1.el7.remi              remi-php72       76 k
 php-gmp                               x86_64      7.2.6-1.el7.remi              remi-php72       66 k
 php-google-recaptcha                  noarch      1.1.3-1.el7.remi              remi             13 k
 php-intl                              x86_64      7.2.6-1.el7.remi              remi-php72      214 k
 php-jsonlint                          noarch      1.7.1-1.el7.remi              remi             16 k
 php-justinrainbow-json-schema5        noarch      5.2.7-1.el7.remi              remi             40 k
 php-mbstring                          x86_64      7.2.6-1.el7.remi              remi-php72      621 k
 php-mysqlnd                           x86_64      7.2.6-1.el7.remi              remi-php72      231 k
 php-paragonie-random-compat           noarch      2.0.12-1.el7.remi             remi             25 k
 php-password-compat                   noarch      1.0.4-1.el7.remi              remi            9.5 k
 php-pdo                               x86_64      7.2.6-1.el7.remi              remi-php72      124 k
 php-pecl-zip                          x86_64      1.15.2-1.el7.remi.7.2         remi-php72       50 k
 php-phpmyadmin-motranslator           noarch      4.0-1.el7.remi                remi             20 k
 php-phpmyadmin-shapefile              noarch      2.1-1.el7.remi                remi             20 k
 php-phpmyadmin-sql-parser             noarch      4.2.4-3.el7.remi              remi            156 k
 php-phpseclib                         noarch      2.0.11-1.el7.remi             remi            209 k
 php-psr-container                     noarch      1.0.0-1.el7.remi              remi            5.9 k
 php-recode                            x86_64      7.2.6-1.el7.remi              remi-php72       45 k
 php-seld-cli-prompt                   noarch      1.0.3-1.el7.remi              remi            7.6 k
 php-seld-phar-utils                   noarch      1.0.1-2.el7.remi              remi            6.8 k
 php-symfony-browser-kit               noarch      2.8.41-1.el7.remi             remi             24 k
 php-symfony-class-loader              noarch      2.8.41-1.el7.remi             remi             27 k
 php-symfony-common                    noarch      2.8.41-1.el7.remi             remi            144 k
 php-symfony-config                    noarch      2.8.41-1.el7.remi             remi             54 k
 php-symfony-console                   noarch      2.8.41-1.el7.remi             remi             89 k
 php-symfony-css-selector              noarch      2.8.41-1.el7.remi             remi             38 k
 php-symfony-debug                     noarch      2.8.41-1.el7.remi             remi             38 k
 php-symfony-dependency-injection      noarch      2.8.41-1.el7.remi             remi             85 k
 php-symfony-dom-crawler               noarch      2.8.41-1.el7.remi             remi             32 k
 php-symfony-event-dispatcher          noarch      2.8.41-1.el7.remi             remi             25 k
 php-symfony-expression-language       noarch      2.8.41-1.el7.remi             remi             29 k
 php-symfony-filesystem                noarch      2.8.41-1.el7.remi             remi             24 k
 php-symfony-finder                    noarch      2.8.41-1.el7.remi             remi             40 k
 php-symfony-http-foundation           noarch      2.8.41-1.el7.remi             remi             96 k
 php-symfony-http-kernel               noarch      2.8.41-1.el7.remi             remi            100 k
 php-symfony-polyfill                  noarch      1.8.0-1.el7.remi              remi             38 k
 php-symfony-process                   noarch      2.8.41-1.el7.remi             remi             33 k
 php-symfony-var-dumper                noarch      2.8.41-1.el7.remi             remi             50 k
 php-symfony-yaml                      noarch      2.8.41-1.el7.remi             remi             30 k
 php-symfony3-common                   noarch      3.4.11-1.el7.remi             remi            119 k
 php-symfony3-translation              noarch      3.4.11-1.el7.remi             remi             66 k
 php-twig                              noarch      1.35.3-1.el7.remi.7.2         remi-php72      163 k
 php-twig-extensions                   noarch      1.5.1-1.el7.remi              remi             23 k

Transaction Summary
=======================================================================================================
Install  1 Package (+49 Dependent packages)

Total download size: 8.8 M
Installed size: 40 M
Is this ok [y/d/N]: 
Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Can't update phpmyadmin 4.7.3 -> 4.8.1

It's not working for me sad
What can I do to get the latest phpmyadmin?

Re: Can't update phpmyadmin 4.7.3 -> 4.8.1

try

yum clean all
yum --enablerepo=remi list php-symfony-http-kernel
Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Can't update phpmyadmin 4.7.3 -> 4.8.1

root@caprica ~# yum --enablerepo=remi list php-symfony-http-kernel
Loaded plugins: changelog, fastestmirror
Determining fastest mirrors
epel/x86_64/metalink                                                                                                                                                                    |  29 kB  00:00:00
* base: centos.hitme.net.pl
* elrepo: dfw.mirror.rackspace.com
* epel: epel.besthosting.ua
* extras: centos2.hti.pl
* remi: fr2.rpmfind.net
* remi-php71: fr2.rpmfind.net
* remi-safe: fr2.rpmfind.net
* updates: centos.hitme.net.pl
base                                                                                                                                                                                    | 3.6 kB  00:00:00
elrepo                                                                                                                                                                                  | 2.9 kB  00:00:00
epel                                                                                                                                                                                    | 4.7 kB  00:00:00
extras                                                                                                                                                                                  | 3.4 kB  00:00:00
lynis                                                                                                                                                                                   | 2.4 kB  00:00:00
mariadb                                                                                                                                                                                 | 2.9 kB  00:00:00
ocsinventory                                                                                                                                                                            | 2.9 kB  00:00:00
remi-php71                                                                                                                                                                              | 2.9 kB  00:00:00
remi-safe                                                                                                                                                                               | 2.9 kB  00:00:00
updates                                                                                                                                                                                 | 3.4 kB  00:00:00
zabbix                                                                                                                                                                                  | 2.9 kB  00:00:00
zabbix-non-supported                                                                                                                                                                    |  951 B  00:00:00
(1/14): elrepo/primary_db                                                                                                                                                               | 544 kB  00:00:00
(2/14): epel/x86_64/group_gz                                                                                                                                                            |  88 kB  00:00:00
(3/14): base/7/x86_64/group_gz                                                                                                                                                          | 166 kB  00:00:00
(4/14): base/7/x86_64/primary_db                                                                                                                                                        | 5.9 MB  00:00:01
(5/14): epel/x86_64/updateinfo                                                                                                                                                          | 930 kB  00:00:01
(6/14): ocsinventory/x86_64/primary_db                                                                                                                                                  |  25 kB  00:00:00
(7/14): extras/7/x86_64/primary_db                                                                                                                                                      | 147 kB  00:00:00
(8/14): remi-php71/primary_db                                                                                                                                                           | 218 kB  00:00:00
(9/14): lynis/primary_db                                                                                                                                                                | 7.0 kB  00:00:00
(10/14): zabbix/x86_64/primary_db                                                                                                                                                       |  87 kB  00:00:00
(11/14): mariadb/primary_db                                                                                                                                                             |  48 kB  00:00:00
(12/14): remi-safe/primary_db                                                                                                                                                           | 1.2 MB  00:00:00
(13/14): updates/7/x86_64/primary_db                                                                                                                                                    | 2.0 MB  00:00:00
(14/14): epel/x86_64/primary_db                                                                                                                                                         | 6.4 MB  00:00:01
zabbix-non-supported/x86_64/primary                                                                                                                                                     | 1.6 kB  00:00:00
zabbix-non-supported                                                                                                                                                                                       4/4
Error: No matching Packages to list

Re: Can't update phpmyadmin 4.7.3 -> 4.8.1

I don't understand... the package is there, there's must be something wrong on your configuration, but can find what...

Try

yum install https://rpms.remirepo.net/enterprise/7/remi/x86_64/php-symfony-http-kernel-2.8.41-1.el7.remi.noarch.rpm
Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

8 (edited by KB7777 2018-05-30 09:01:52)

Re: Can't update phpmyadmin 4.7.3 -> 4.8.1

Remi, sorry for stealing your time sad
I have "exclude=*kernel" in /etc/yum.conf to prevent kernel updates...

"yum --disableexcludes=all --enablerepo=remi list php-symfony-http-kernel" works fine.

EDIT:
I tried earlier "yum install https://rpms.remirepo.net/enterprise/7/remi/x86_64/php-symfony-http-kernel-2.8.41-1.el7.remi.noarch.rpm" but "exlude=*kernel" prevents this too, so the exclude works very, very solid. Good to know smile

Re: Can't update phpmyadmin 4.7.3 -> 4.8.1

smile

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test