Topic: libzip5 dependency issue

Hello,

i ran into a dependency issue where libzip5(x86-64) = 1.4.0-2.el7.remi is installed and
libzip5(x86-64) >= 1.5.1 is needed.

---> Paket php-pecl-zip.x86_64 0:1.15.3-1.el7.remi.7.2 markiert, um eine Aktualisierung zu werden
--> Abhängigkeit libzip5(x86-64) >= 1.5.1 wird für Paket php-pecl-zip-1.15.3-1.el7.remi.7.2.x86_64 verarbeitet
--> Abhängigkeitsauflösung beendet
Fehler: Paket: php-pecl-zip-1.15.3-1.el7.remi.7.2.x86_64 (remi-php72)
            Benötigt: libzip5(x86-64) >= 1.5.1
            Installiert: libzip5-1.4.0-2.el7.remi.x86_64 (@remi-safe)
                libzip5(x86-64) = 1.4.0-2.el7.remi
 Sie können versuchen, mit --skip-broken das Problem zu umgehen.
 Sie könnten Folgendes versuchen: rpm -Va --nofiles --nodigest

I tried "yum list libzip5" but only
libzip5.x86_64  1.4.0-2.el7.remi  @remi-safe
is available. Could you please help me how to safely resolve this dependency issue?

Many thanks in advance!

Re: libzip5 dependency issue

Don't know, libzip5 version 1.5.1 is there for months.

See https://rpms.remirepo.net/enterprise/7/ … bzip5.html

Check that remi-safe is enabled.

Else, please post FULL yum ouput, with LANG=C

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: libzip5 dependency issue

Hi Remi,

you're right. Haven't seen that the remi-safe wasn't enabled.
Thanks again!