Topic: PHP 7.1 ImageMagick Missing Dependencies

Hello, thank you for all the hard work you put into maintaining the repository. I am new to CentOS 7 and have searched for hours through Google and numerous forums to find a solution as to the problem, however I am still stuck , sleepy and frustrated.

I am attempting to install the PHP extension ImageMagick on Centos 7.5.1804, Php 7.1.23 however I am told there are missing dependencies and cannot seem to figure out how in the heck to resolve the issue.

yum install php71w-pecl-imagick.x86_64

results in:

Error: Package: php-pecl-imagick-3.4.3-9.el7.remi.7.1.x86_64 (remi-php71)
           Requires: libMagickWand-6.Q16.so.6()(64bit)
Error: Package: php-pecl-imagick-3.4.3-9.el7.remi.7.1.x86_64 (remi-php71)
           Requires: libMagickCore-6.Q16.so.6()(64bit)
Error: Package: php-pecl-imagick-3.4.3-9.el7.remi.7.1.x86_64 (remi-php71)
           Requires: ImageMagick6-libs(x86-64) >= 6.9.9

Re: PHP 7.1 ImageMagick Missing Dependencies

Please: yum repolist

Looks like "remi-safe" repository is missing.

See the Wizard instructions (top right link) for proper configuration / installation.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: PHP 7.1 ImageMagick Missing Dependencies

Right on and thank you for the speedy reply. It occurred to me that I likely messed up the repos when downgrading from PHP 7.2 to PHP 7.1

Per your request running Yum repolist returns the following

Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.genesisadaptive.com
 * extras: ftp.ussg.iu.edu
 * remi-php71: mirror.team-cymru.com
 * updates: mirror.mobap.edu
 * webtatic: us-east.repo.webtatic.com
repo id           repo name                                               status
!base/7/x86_64    CentOS-7 - Base                                         9,911
!extras/7/x86_64  CentOS-7 - Extras                                         432
!mongodb-org/7    MongoDB Repository                                         45
!remi-php71       Remi's PHP 7.1 RPM repository for Enterprise Linux 7 -    397
!updates/7/x86_64 CentOS-7 - Updates                                      1,543
!webtatic/x86_64  Webtatic Repository EL7 - x86_64                        1,177
repolist: 13,505

In addition when I attempt to install either EPEL or Remi 7.5-2.el7.remi.noarch the terminal window spits on me:

Preparing...                          ################################# [100%]
    package remi-release-7.5-2.el7.remi.noarch is already installed

I apologize in advance as I am new to this whole admin completely from a terminal window concept as I have mostly worked in A/V production. smile

Re: PHP 7.1 ImageMagick Missing Dependencies

So "remi-safe" is missing. Enable it and missing dependencies will be found there.

yum-config-manager --enable remi-safe

P.S. if /etc/yum.repos.d/remi-safe.repo configuration file is missing, you will have to reinstall the remi-release package to restore it.

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test