Topic: Problème upgrade GLPI 9.3.1 vers 9.3.2

bonjour

j'ai installé il y a plusieurs mois GLPI sur une distri Fedora28
j'ai plusieurs fois fait les mises à jours via le repo sans problème
je suis actuellement en 9.3.1

cette fois après l'upgrade vers 9.3.2 (check OK - upgrade DB OK) j'ai un message d'erreur :
Fatal error: Interface 'Psr\SimpleCache\CacheInterface' not found in /usr/share/php/Zend/Cache/Psr/SimpleCache/SimpleCacheDecorator.php on line 26

auriez-vous une idée ?

merci d'avance :-)

Re: Problème upgrade GLPI 9.3.1 vers 9.3.2

Merci pour le rapport

Effectivement, il y a un soucis qui n'affecte que Fedora (et comme 99% des utilisateurs sont sous EL, personne ne l'a encore signalé)

La mise à jour de php-zendframework-zend-cache-2.8.2-4 doit corriger le soucis (merci de me le confirmer)

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Problème upgrade GLPI 9.3.1 vers 9.3.2

bonjour

j'ai résolu le problème en écrasant le répertoire glpi avec les fichiers récupérés de l'archive officielle ...
plus de souci après ça ....

Re: Problème upgrade GLPI 9.3.1 vers 9.3.2

bah... c'est particulièrement crade...

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: Problème upgrade GLPI 9.3.1 vers 9.3.2

MDR
probablement, je n'ai aucune connaissance en linux au départ .... :-)