Topic: Unable to update 8.2.2004 with some packages from Remi

Hello

When trying to update an OS, I'm getting the following error

[root@ispcc ~]# yum update
Last metadata expiration check: 1:29:58 ago on Sun 20 Dec 2020 06:16:43 PM EET.
Error:
Problem 1: package php-pecl-krb5-1.1.4-1.el8.remi.7.4.x86_64 requires libkadm5clnt_mit.so.11()(64bit), but none of the providers can be installed
  - package php-pecl-krb5-1.1.4-1.el8.remi.7.4.x86_64 requires libkadm5clnt_mit.so.11(kadm5clnt_mit_11_MIT)(64bit), but none of the providers can be installed
  - cannot install both libkadm5-1.18.2-5.el8.x86_64 and libkadm5-1.17-18.el8.x86_64
  - cannot install the best update candidate for package php-pecl-krb5-1.1.4-1.el8.remi.7.4.x86_64
  - cannot install the best update candidate for package libkadm5-1.17-18.el8.x86_64
Problem 2: problem with installed package php-pecl-krb5-1.1.4-1.el8.remi.7.4.x86_64
  - package php-pecl-krb5-1.1.4-1.el8.remi.7.4.x86_64 requires libkadm5clnt_mit.so.11()(64bit), but none of the providers can be installed
  - package php-pecl-krb5-1.1.4-1.el8.remi.7.4.x86_64 requires libkadm5clnt_mit.so.11(kadm5clnt_mit_11_MIT)(64bit), but none of the providers can be installed
  - cannot install both libkadm5-1.18.2-5.el8.x86_64 and libkadm5-1.17-18.el8.x86_64
  - package krb5-devel-1.18.2-5.el8.x86_64 requires libkadm5(x86-64) = 1.18.2-5.el8, but none of the providers can be installed
  - cannot install the best update candidate for package krb5-devel-1.17-18.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)



I'm little bit confused to understand which package conflicts with which package... How to fix it?

Thanks



Some data about the system

[root@ispcc ~]# uname -a
Linux ispcc.isphost.net 4.18.0-193.28.1.el8_2.x86_64 #1 SMP Thu Oct 22 00:20:22 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
[root@ispcc ~]# more /etc/redhat-release
CentOS Linux release 8.2.2004 (Core)


[root@ispcc ~]# ls -la /etc/yum.repos.d/
total 100
drwxr-xr-x.   2 root root 4096 Nov 16 19:02 .
drwxr-xr-x. 111 root root 8192 Dec 18 20:32 ..
-rw-r--r--.   1 root root  731 Sep 15 23:10 CentOS-AppStream.repo
-rw-r--r--.   1 root root  712 Sep 15 23:10 CentOS-Base.repo
-rw-r--r--.   1 root root  798 Sep 15 23:10 CentOS-centosplus.repo
-rw-r--r--.   1 root root 1043 Sep 15 23:10 CentOS-CR.repo
-rw-r--r--.   1 root root  668 Sep 15 23:10 CentOS-Debuginfo.repo
-rw-r--r--.   1 root root  743 Sep 15 23:10 CentOS-Devel.repo
-rw-r--r--.   1 root root  756 Sep 15 23:10 CentOS-Extras.repo
-rw-r--r--.   1 root root  338 Sep 15 23:10 CentOS-fasttrack.repo
-rw-r--r--.   1 root root  738 Sep 15 23:10 CentOS-HA.repo
-rw-r--r--.   1 root root  928 Sep 15 23:10 CentOS-Media.repo
-rw-r--r--.   1 root root  734 Oct  4 22:55 CentOS-PowerTools.repo
-rw-r--r--.   1 root root 1382 Sep 15 23:10 CentOS-Sources.repo
-rw-r--r--.   1 root root   74 Sep 15 23:10 CentOS-Vault.repo
-rw-r--r--    1 root root 1177 Oct 31 22:31 epel-modular.repo
-rw-r--r--    1 root root 1259 Oct 31 22:31 epel-playground.repo
-rw-r--r--    1 root root 1114 Oct 31 22:31 epel.repo
-rw-r--r--    1 root root 1276 Oct 31 22:31 epel-testing-modular.repo
-rw-r--r--    1 root root 1213 Oct 31 22:31 epel-testing.repo
-rw-r--r--    1 root root  903 Feb 27  2020 remi-modular.repo
-rw-r--r--    1 root root 1379 Nov 19 13:30 remi.repo
-rw-r--r--    1 root root  778 Feb 27  2020 remi-safe.repo

Re: Unable to update 8.2.2004 with some packages from Remi

Thanks for the report.

Indeed, krb5 was updated from 1.17 to 1.18 in 8.3, raising this issue.

New build (1.1.4-3) fixes this issue
(build against new version)

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Unable to update 8.2.2004 with some packages from Remi

Remi wrote:

Thanks for the report.

Indeed, krb5 was updated from 1.17 to 1.18 in 8.3, raising this issue.

New build (1.1.4-3) fixes this issue
(build against new version)

Thank you for response. Did not clearly understood, this new build is available somewhere or I should rebuild the package some special way?

Re: Unable to update 8.2.2004 with some packages from Remi

New build is in the repository
Will be on all mirrors soon

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi