1 (edited by reporter4u 2021-04-19 15:18:19)

Topic: Error: Package: drush-8.1.16-1.el7.remi.noarch during installation

Hi all! Thank you in advance for any help or suggestion.

I'm facing this problem with Drush 8.1.16 (remi) installation on a Centos 7.9 distribution. I installed it more than one year ago, the same version, on previous version of Centos 7 (7.4/7.5) without any problems. But this is the error I got now:

yum install drush --enablerepo remi
...
Error: Package: drush-8.1.16-1.el7.remi.noarch (remi)
           Requires: php-composer(consolidation/output-formatters) < 4
           Removing: php-consolidation-output-formatters-3.1.7-1.el7.noarch (@epel)
               php-composer(consolidation/output-formatters) = 3.1.7
           Updated By: php-consolidation-output-formatters-4.1.2-1.el7.remi.noarch (remi)
               php-composer(consolidation/output-formatters) = 4.1.2
           Available: php-consolidation-output-formatters-4.1.1-1.el7.remi.noarch (remi)
               php-composer(consolidation/output-formatters) = 4.1.1
Error: Package: drush-8.1.16-1.el7.remi.noarch (remi)
           Requires: php-composer(consolidation/annotated-command) < 3
           Removing: php-consolidation-annotated-command-2.4.8-1.el7.noarch (@epel)
               php-composer(consolidation/annotated-command) = 2.4.8
           Updated By: php-consolidation-annotated-command-4.2.4-1.el7.remi.noarch (remi)
               php-composer(consolidation/annotated-command) = 4.2.4
           Available: php-consolidation-annotated-command-4.2.1-1.el7.remi.noarch (remi)
               php-composer(consolidation/annotated-command) = 4.2.1

It seems weird that yum is trying to remove the installed (epel) version of both packages (php-consolidation-output-formatters < 4 and php-consolidation-annotated-command < 3) which are alraedy observing the conditions about the version, in favor of newer versions in remi repository which don't observe version conditions since they are above the limits.
The problem occurs even if these packages weren't installed before:

Error: Package: drush-8.1.16-1.el7.remi.noarch (remi)
           Requires: php-composer(consolidation/output-formatters) < 4
           Available: php-consolidation-output-formatters-3.1.7-1.el7.noarch (epel)
               php-composer(consolidation/output-formatters) = 3.1.7
           Available: php-consolidation-output-formatters-4.1.1-1.el7.remi.noarch (remi)
               php-composer(consolidation/output-formatters) = 4.1.1
           Installing: php-consolidation-output-formatters-4.1.2-1.el7.remi.noarch (remi)
               php-composer(consolidation/output-formatters) = 4.1.2
Error: Package: drush-8.1.16-1.el7.remi.noarch (remi)
           Requires: php-composer(consolidation/annotated-command) < 3
           Available: php-consolidation-annotated-command-2.4.8-1.el7.noarch (epel)
               php-composer(consolidation/annotated-command) = 2.4.8
           Available: php-consolidation-annotated-command-4.2.1-1.el7.remi.noarch (remi)
               php-composer(consolidation/annotated-command) = 4.2.1
           Installing: php-consolidation-annotated-command-4.2.4-1.el7.remi.noarch (remi)
               php-composer(consolidation/annotated-command) = 4.2.4



In order to make troubleshooting I tried also to install apart and before drush these newer packages in order to discover the problem but got this error:

Error: Package: drush-8.1.16-1.el7.remi.noarch (remi)
           Requires: php-composer(consolidation/output-formatters) < 4
           Installed: php-consolidation-output-formatters-4.1.2-1.el7.remi.noarch (@remi)
               php-composer(consolidation/output-formatters) = 4.1.2
           Available: php-consolidation-output-formatters-3.1.7-1.el7.noarch (epel)
               php-composer(consolidation/output-formatters) = 3.1.7
           Available: php-consolidation-output-formatters-4.1.1-1.el7.remi.noarch (remi)
               php-composer(consolidation/output-formatters) = 4.1.1
Error: Package: drush-8.1.16-1.el7.remi.noarch (remi)
           Requires: php-composer(consolidation/annotated-command) < 3
           Installed: php-consolidation-annotated-command-4.2.4-1.el7.remi.noarch (@remi)
               php-composer(consolidation/annotated-command) = 4.2.4
           Available: php-consolidation-annotated-command-2.4.8-1.el7.noarch (epel)
               php-composer(consolidation/annotated-command) = 2.4.8
           Available: php-consolidation-annotated-command-4.2.1-1.el7.remi.noarch (remi)
               php-composer(consolidation/annotated-command) = 4.2.1

Why doesn't yum take the right version?

Any ideas or suggestions?

Thank you.

Re: Error: Package: drush-8.1.16-1.el7.remi.noarch during installation

Indeed, it looks like I miss this package during the EL7 mass update
Should be fixed now (8.1.16-6, allow latest versions of php-consolidation*)


P.S. yum is confused by dual constraint for min and max version... recent yum/dnf version in Fedora and EL8 is much better allowing range dependencies...

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Error: Package: drush-8.1.16-1.el7.remi.noarch during installation

I tested your fix and work fine.

Thank you very much!

Re: Error: Package: drush-8.1.16-1.el7.remi.noarch during installation

smile

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi