1

Topic: php-redis

Hi Remi

When i try to install php74-php-pecl-redis4-4.3.0-3.el8.remi.x86_64 on a CentOS8

i get:

Error:
Problem: conflicting requests
  - nothing provides php74-php(api) = 20190529-64 needed by php74-php-pecl-redis4-4.3.0-3.el8.remi.x86_64
  - nothing provides php74-php(zend-abi) = 20190529-64 needed by php74-php-pecl-redis4-4.3.0-3.el8.remi.x86_64

please advise

best
fa

Re: php-redis

For a proper configuration, please follow the Wizard instructions (link on top right corner of all pages)

Notice: latest (recommended) version is 5.3.4
See https://blog.remirepo.net/pages/PECL-ex … RPM-status


P.S. and not enough information, which PHP version is installed, which provider, which repository configuration...

Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: php-redis

When the system is properly configured:

For latest version

# dnf install php-redis
...
Dependencies resolved.
====================================================================================================================================================================================
 Package                                      Architecture                        Version                                           Repository                                 Size
====================================================================================================================================================================================
Installing:
 php-pecl-redis5                              x86_64                              5.3.4-1.el8.remi.7.4                              remi-modular                              262 k

Transaction Summary
====================================================================================================================================================================================
Install  1 Package

Total download size: 262 k
Installed size: 1.5 M
Is this ok [y/N]: 

Or For older version (but only for PHP <= 7.3)

# dnf install php-pecl-redis4
Last metadata expiration check: 0:00:22 ago on Mon Jun 21 09:25:04 2021.
Dependencies resolved.
====================================================================================================================================================================================
 Package                                      Architecture                        Version                                           Repository                                 Size
====================================================================================================================================================================================
Installing:
 php-pecl-redis4                              x86_64                              4.3.0-2.el8.remi.7.3                              remi-modular                              240 k

Transaction Summary
====================================================================================================================================================================================
Install  1 Package

Total download size: 240 k
Installed size: 1.3 M
Is this ok [y/N]: 
Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

4

Re: php-redis

Hi Remi

I know the recommended version is newer, and this one can be installed without a problem, but the client needs it hmm

php 5.6 to 8.0 are installed.....

dnf info php74-php-pecl-redis4.x86_64
Last metadata expiration check: 0:51:39 ago on Mon 21 Jun 2021 04:16:46 PM CEST.
Available Packages
Name         : php74-php-pecl-redis4
Version      : 4.3.0
Release      : 3.el8.remi
Architecture : x86_64
Size         : 202 k
Source       : php74-php-pecl-redis4-4.3.0-3.el8.remi.src.rpm
Repository   : remi-safe

Re: php-redis

I understand

This is an old package, build during 7.4 dev phase, before its final ABI.

* PHP 5.4 to 7.2 have 3.1.6
* PHP 5.4 to 7.4 have 4.3.0 (default since 7.3 or Fedora 29 or EL 8)
* PHP 7.0 to 8.1 have 5.3.4 (default since 7.4 or Fedora 31 or EL 9)

So it was not planed to support 4.3 for PHP 7.4 (in my repo)


As I'm probably too kind, a new rebuild should allow its installation, and is now in the repository

# dnf install php74-php-pecl-redis4.x86_64
Last metadata expiration check: 0:00:22 ago on Mon Jun 21 18:49:00 2021.
Dependencies resolved.
===================================================================================================================
 Package                             Architecture       Version                        Repository             Size
===================================================================================================================
Installing:
 php74-php-pecl-redis4               x86_64             4.3.0-4.el8.remi               remi-safe             202 k
Installing dependencies:
 php74-php-pecl-igbinary             x86_64             3.2.3-1.el8.remi               remi-safe             108 k

Transaction Summary
===================================================================================================================
Install  2 Packages

Total download size: 310 k
Installed size: 1.0 M
Is this ok [y/N]: 

But, please, understand it won't be supported, using a deprecated version of phpredis on a recent PHP version is not serious.
And in all case you will have to switch to 5.x for PHP 8.x (or perhaps 6.x)


And be aware than a simple  update will switch to the newer version

# dnf update
Last metadata expiration check: 0:00:56 ago on Mon Jun 21 18:49:00 2021.
Dependencies resolved.
===================================================================================================================
 Package                            Architecture       Version                         Repository             Size
===================================================================================================================
Installing:
 php74-php-pecl-redis5              x86_64             5.3.4-1.el8.remi                remi-safe             227 k
     replacing  php74-php-pecl-redis4.x86_64 4.3.0-4.el8.remi
Installing dependencies:
 php74-php-pecl-msgpack             x86_64             2.1.2-1.el8.remi                remi-safe              48 k

Transaction Summary
===================================================================================================================
Install  2 Packages

Total download size: 275 k
Is this ok [y/N]: 
Desktop: Fedora 33 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 34 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

6

Re: php-redis

Hi Remi

Thank you very much for the rebuild.
I already informed the client that he will have to switch to php-pecl-redis5 with php8.


keep a the good work
thx again