Topic: Problem upgrading php-gd from 7.4.26 to 7.4.27

Im trying to upgrade my php to the latest avaailble php 7.4 version, but when I execute the update command (yum or dnf update php) Im getting the error below.

Problem: package php-gd-7.4.27-1.el8.remi.x86_64 requires libgd.so.103()(64bit), but none of the providers can be installed
  - cannot install the best candidate for the job
  - nothing provides libraqm.so.0()(64bit) needed by gd3php-2.3.3-4.el8.remi.x86_64
  - nothing provides libimagequant.so.0()(64bit) needed by gd3php-2.3.3-4.el8.remi.x86_64

Any suggestions to fix this ?

Thank you.

Re: Problem upgrading php-gd from 7.4.26 to 7.4.27

For a proper installation you have to follow the wizard instructions
https://rpms.remirepo.net/wizard/

So you need EPEL repository

Also explained in the FAQ
https://blog.remirepo.net/pages/English-FAQ#deps

Both libraqm and libimagequant are provided by EPEL.

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Problem upgrading php-gd from 7.4.26 to 7.4.27

I tried checking my epel repo and it was disabled in my yum settings. Tried to enable that and dependencies are automatically downloaded.
I can now use the 7.4.27 version of GD.

Thank you very much!

Re: Problem upgrading php-gd from 7.4.26 to 7.4.27

smile

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi