1 (edited by Kofl 2022-01-08 17:48:57)

Topic: php74-php-pecl-gmagick conflicts with php74-php-pecl-imagick-im7?

Hi,

I have gmagick installed for Centos 7, but want to add imagick for better Wordpress support.

yum install php74-php-pecl-imagick-im7

Error: php74-php-pecl-gmagick conflicts with php74-php-pecl-imagick-im7-3.6.0-2.el7.remi.x86_64
Error: php74-php-pecl-imagick-im7 conflicts with php74-php-pecl-gmagick-2.0.6~RC1-1.el7.remi.x86_64

[root@www7 ~]# rpm -qa | grep gmagick
php71-php-pecl-gmagick-2.0.6~RC1-1.el7.remi.x86_64
php74-php-pecl-gmagick-2.0.6~RC1-1.el7.remi.x86_64
php56-php-pecl-gmagick-1.1.7-0.6.RC3.el7.remi.x86_64
php80-php-pecl-gmagick-2.0.6~RC1-1.el7.remi.x86_64
php70-php-pecl-gmagick-2.0.6~RC1-1.el7.remi.x86_64
php72-php-pecl-gmagick-2.0.6~RC1-1.el7.remi.x86_64

Are they really incompatible or did I mess up anything?

Thanks

Re: php74-php-pecl-gmagick conflicts with php74-php-pecl-imagick-im7?

This is expected, you cannot install both gmagick  and gmagick

As GraphicsMagick is a fork of ImageMagick, both cannot be load in the same process (else you will have segfault)

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: php74-php-pecl-gmagick conflicts with php74-php-pecl-imagick-im7?

Thanks for the quick repsonse and clarification.