Topic: Cannot install remi-release-8.rpm on RHEL 8.4

Hello. I appreciate any help at all.

I am trying to follow the Wizard's instructions to install the latest PHP on RHEL 8.4. It says to first do this:
dnf install ... //dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm
dnf install ... //rpms.remirepo.net/enterprise/remi-release-8.rpm

The first install was successful and dnf reported it installed version "epel-release-8-14.el8.noarch".

But when I try the second install, dnf gives me the error:
"Problem: conflicting requests - nothing provides redhat-release >= 8.5 needed by remi-release-8.5-3.el8.remi.noarch"

The command "uname -or" reports "4.18.0-305.34.2.el8_4.x86_64 GNU/Linux".

Are there any other clues I can provide?

Than you!
-Alan

Re: Cannot install remi-release-8.rpm on RHEL 8.4

> "Problem: conflicting requests - nothing provides redhat-release >= 8.5 needed by remi-release-8.5-3.el8.remi.noarch"

Sorry, but I cannot support old versions.
You are running 8.4, while the latest is 8.5
So you have to update first
(a simple "dnf update" should be enough)

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi

Re: Cannot install remi-release-8.rpm on RHEL 8.4

I just want to point out that I was using the wizard instructions for "RHEL 8.4" and that following those instructions to completion requires RHEL >= 8.5. So if you require 8.5, you should change the text of the menu selection in the wizard to read "RHEL 8.5" instead.

Re: Cannot install remi-release-8.rpm on RHEL 8.4

I also want to point out that, for critical enterprise solutions, you really should support RHEL 8.4 until 8.6 is stable and supported by you. According to https://access.redhat.com/support/polic … es/errata/ the support cycle for odd-numbered revisions (like 8.5) is only 6 months. The expert sysadmins in my company are recommending against using RHEL 8.5 in our business-critical environment. Therefore, I was forced to find other solutions and will no longer be relying on your repository. (We also wish to avoid single-points-of-failure.)

Re: Cannot install remi-release-8.rpm on RHEL 8.4

I'm perfectly aware of RHEL life cycle.

Currently supported versions are 8.1, 8.2, 8.4 and 8.5
sorry, but building everything for 3 more versions is not sustainable
especially as very few users stay on old RHEL

P.S. and using my repository is still possible, but I won't support it.

Desktop: Fedora 35 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 36 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 8 Stream with EPEL, rpmfusion, remi