Topic: 503 when connecting to rpos

I'm trying to install PHP 8.2 on RHEL 8.8, but I get the following error when I add the remi-release repo. URLs removed due to posting restrictions:
Running transaction
  Preparing        :                                                                            1/1
  Installing       : remi-release-8.8-1.el8.remi.noarch                                         1/1
  Verifying        : remi-release-8.8-1.el8.remi.noarch                                         1/1
Installed products updated.
Errors during downloading metadata for repository 'remi-modular':
  - Status code: 503 for X (IP: 176.31.103.194)
  - Status code: 503 for X (IP: 109.238.14.107)

I also see this 503 when I try to reset php:
Remi's Modular repository for Enterprise Linux 8 - x86_64           1.0 kB/s | 1.9 kB     00:01
Errors during downloading metadata for repository 'remi-modular':
  - Status code: 503 for X (IP: 176.31.103.194)
  - Status code: 503 for X (IP: 109.238.14.107)
Error: Failed to download metadata for repo 'remi-modular': Cannot prepare internal mirrorlist: Status code: 503 for X (IP: 176.31.103.194)

I'm able to curl http://cdn.remirepo.net/enterprise/8/mo … 64/mirror, so I'm not sure what's wrong.
I have tried this on 2 VMs, with the same outcome. Please have a look at your mirrors & let me know how to proceed.

Re: 503 when connecting to rpos

> I'm able to curl http://cdn.remirepo.net/enterprise/8/mo … _64/mirror so I'm not sure what's wrong.

If this URL works... no idea what's wrong
Have you tried the curl from the same VM ?

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: 503 when connecting to rpos

I tried curl from both affected VMs and get the same response, but still get the 503 from dnf/yum:
# curl -v http://cdn.remirepo.net/enterprise/8/mo … _64/mirror
*   Trying 176.31.103.194...
* TCP_NODELAY set
* Connected to cdn.remirepo.net (176.31.103.194) port 80 (#0)
> GET /enterprise/8/modular/x86_64/mirror HTTP/1.1
> Host: cdn.remirepo.net
> User-Agent: curl/7.61.1
> Accept: */*
>
< HTTP/1.1 200 OK
< date: Tue, 20 Jun 2023 15:00:27 GMT
< server: Apache/2.4.37 (centos) OpenSSL/1.1.1k
< etag: "f4b-5fa22a44b78b8"
< last-modified: Tue, 25 Apr 2023 05:46:15 GMT
< content-length: 3915
< age: 29
< x-cache: HIT
< accept-ranges: bytes
<
BUNCH OF URLS HERE IT WON'T LET ME LIST
* Connection #0 to host cdn.remirepo.net left intact

Re: 503 when connecting to rpos

Proxy issue ?

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: 503 when connecting to rpos

From log, ~2000 requests per minute  are served with success (200)

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: 503 when connecting to rpos

We don't use a proxy, thus my confusion. I was able to add the EPEL repos without issue, so I don't understand why I'm having issues with the Remi repos.

Re: 503 when connecting to rpos

OK, I'll dig deeper on my end. Thanks for checking.

Re: 503 when connecting to rpos

This turned out to be an enterprise firewall setting, so we're good now. Thanks for your guidance.

Re: 503 when connecting to rpos

smile

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi