Topic: php8.2 - php-intl won't install as libicudata.so.72 not found

Remi,

Just seeing this today.  CentOS7 latest, and getting the dependency issue that libicudata.so.72 is required, but the repo only contains upto 71.

Larry

Details:

[root@vmhost3 ~]# yum install php-intl
Loaded plugins: auto-update-debuginfo, fastestmirror, langpacks, nvidia, priorities
Loading mirror speeds from cached hostfile
* base: bay.uchicago.edu
* epel: mirror.steadfastnet.com
* epel-debuginfo: mirror.steadfastnet.com
* extras: mirror.genesishosting.com
* remi-php82: cdn.centos.no
* updates: ftpmirror.your.org
7 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package php-intl.x86_64 0:8.2.7-2.el7.remi will be installed
--> Processing Dependency: libicudata.so.72()(64bit) for package: php-intl-8.2.7-2.el7.remi.x86_64
--> Processing Dependency: libicui18n.so.72()(64bit) for package: php-intl-8.2.7-2.el7.remi.x86_64
--> Processing Dependency: libicuio.so.72()(64bit) for package: php-intl-8.2.7-2.el7.remi.x86_64
--> Processing Dependency: libicuuc.so.72()(64bit) for package: php-intl-8.2.7-2.el7.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php-intl-8.2.7-2.el7.remi.x86_64 (remi-php82)
           Requires: libicuuc.so.72()(64bit)
Error: Package: php-intl-8.2.7-2.el7.remi.x86_64 (remi-php82)
           Requires: libicudata.so.72()(64bit)
Error: Package: php-intl-8.2.7-2.el7.remi.x86_64 (remi-php82)
           Requires: libicuio.so.72()(64bit)
Error: Package: php-intl-8.2.7-2.el7.remi.x86_64 (remi-php82)
           Requires: libicui18n.so.72()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Re: php8.2 - php-intl won't install as libicudata.so.72 not found

missing the "remi-safe" repo

for a proper repository configuration and usage, follow the wizard instructions

Also notice that C7 is close to its end of life in < 1 year.
a more recent version is recommended
especially for modern features, such as PHP 8.2

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

3 (edited by TheWitness 2023-07-01 16:09:25)

Re: php8.2 - php-intl won't install as libicudata.so.72 not found

Yea, agree.  I'm just waiting for the Rocky situation to settle, and that's my next destination.