1 (edited by powern 2023-09-27 13:56:26)

Topic: repo not work

system CentOS Stream release 9

[root]#yum repolist
repo id                                                                repo name
appstream                                                              CentOS Stream 9 - AppStream
baseos                                                                 CentOS Stream 9 - BaseOS
crb                                                                    CentOS Stream 9 - CRB
epel-cisco-openh264                                                    Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64
epel-next                                                              Extra Packages for Enterprise Linux 9 - Next - x86_64
extras-common                                                          CentOS Stream 9 - Extras packages
remi-modular                                                           Remi's Modular repository for Enterprise Linux 9 - x86_64
remi-safe                                                              Safe Remi's RPM repository for Enterprise Linux 9 - x86_64
zabbix                                                                 Zabbix Official Repository - x86_64
zabbix-non-supported                                                   Zabbix Official Repository non-supported - x86_64
[root]#dnf update
Last metadata expiration check: 2:27:12 ago on Wed 27 Sep 2023 01:36:12 PM EEST.
Error:
 Problem 1: package php-gd-8.0.30-1.el9.remi.x86_64 from remi-modular requires libgd.so.103()(64bit), but none of the providers can be installed
  - package gd3php-2.3.3-9.el9.remi.x86_64 from remi-safe requires libavif.so.15()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package php-gd-8.0.27-1.el9.x86_64
  - nothing provides libavif.so.14()(64bit) needed by gd3php-2.3.3-8.el9.remi.x86_64 from remi-safe
  - nothing provides libSvtAv1Enc.so.0()(64bit) needed by libavif-0.11.1-0.x86_64 from remi-safe
  - nothing provides libaom.so.3()(64bit) needed by libavif-0.11.1-0.x86_64 from remi-safe
  - nothing provides libdav1d.so.6()(64bit) needed by libavif-0.11.1-0.x86_64 from remi-safe

please help fix the error

Re: repo not work

It works for me

# dnf install php-gd
Updating Subscription Management repositories.
Unable to read consumer identity

This system is not registered with an entitlement server. You can use subscription-manager to register.

Last metadata expiration check: 0:05:16 ago on Wed Sep 27 15:43:43 2023.
Dependencies resolved.
=============================================================================================================================================================================
 Package                                  Architecture                       Version                                          Repository                                Size
=============================================================================================================================================================================
Installing:
 php-gd                                   x86_64                             8.1.24-1.el9.remi                                remi-modular                              62 k
Installing dependencies:
 gd3php                                   x86_64                             2.3.3-9.el9.remi                                 remi                                     136 k
 libavif                                  x86_64                             0.11.1-4.el9                                     epel                                      81 k
 rav1e-libs                               x86_64                             0.6.6-1.el9                                      epel                                     1.0 M
 svt-av1-libs                             x86_64                             0.9.0-1.el9                                      epel                                     1.7 M

Transaction Summary
=============================================================================================================================================================================
Install  5 Packages

Total download size: 3.0 M
Installed size: 10 M
Is this ok [y/N]: 

It seems EPEL is missing (and epel-next is not enough)

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

3 (edited by powern 2023-09-27 13:58:38)

Re: repo not work

Remi wrote:

It works for me

# dnf install php-gd
Updating Subscription Management repositories.
Unable to read consumer identity

This system is not registered with an entitlement server. You can use subscription-manager to register.

Last metadata expiration check: 0:05:16 ago on Wed Sep 27 15:43:43 2023.
Dependencies resolved.
=============================================================================================================================================================================
 Package                                  Architecture                       Version                                          Repository                                Size
=============================================================================================================================================================================
Installing:
 php-gd                                   x86_64                             8.1.24-1.el9.remi                                remi-modular                              62 k
Installing dependencies:
 gd3php                                   x86_64                             2.3.3-9.el9.remi                                 remi                                     136 k
 libavif                                  x86_64                             0.11.1-4.el9                                     epel                                      81 k
 rav1e-libs                               x86_64                             0.6.6-1.el9                                      epel                                     1.0 M
 svt-av1-libs                             x86_64                             0.9.0-1.el9                                      epel                                     1.7 M

Transaction Summary
=============================================================================================================================================================================
Install  5 Packages

Total download size: 3.0 M
Installed size: 10 M
Is this ok [y/N]: 

It seems EPEL is missing (and epel-next is not enough)

dnf install https://dl.fedoraproject.org/pub/epel/9/Everything/x86_64/Packages/e/epel-release-9-7.el9.noarch.rpm
Last metadata expiration check: 0:03:50 ago on Wed 27 Sep 2023 04:49:05 PM EEST.
epel-release-9-7.el9.noarch.rpm                                                                                                                                35 kB/s |  19 kB     00:00
Package epel-release-9-7.el9.noarch is already installed.
Dependencies resolved.
Nothing to do.
Complete!
dnf list |grep epel-release
epel-release.noarch                                           9-7.el9                                  @@commandline

Re: repo not work

Having the epel-release package installed doesn't mean the repository is enabled.

Check with: dnf repolist
Enable it with: dnf config-manager --set-enable epel

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: repo not work

Remi wrote:

Having the epel-release package installed doesn't mean the repository is enabled.

Check with: dnf repolist
Enable it with: dnf config-manager --set-enable epel

# dnf config-manager --set-enable epel
Error: No matching repo to modify: epel.
dnf config-manager --set-enable epel-release
Error: No matching repo to modify: epel-release.

Re: repo not work

dnf config-manager --set-enabled epel*

dnf repolist
repo id                                                                repo name
appstream                                                              CentOS Stream 9 - AppStream
baseos                                                                 CentOS Stream 9 - BaseOS
crb                                                                    CentOS Stream 9 - CRB
epel-cisco-openh264                                                    Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64
epel-cisco-openh264-debuginfo                                          Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64 - Debug
epel-cisco-openh264-source                                             Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64 - Source
epel-next                                                              Extra Packages for Enterprise Linux 9 - Next - x86_64
epel-next-debuginfo                                                    Extra Packages for Enterprise Linux 9 - Next - x86_64 - Debug
epel-next-source                                                       Extra Packages for Enterprise Linux 9 - Next - x86_64 - Source
epel-next-testing                                                      Extra Packages for Enterprise Linux 9 - Next - Testing - x86_64
epel-next-testing-debuginfo                                            Extra Packages for Enterprise Linux 9 - Next - Testing - x86_64 - Debug
epel-next-testing-source                                               Extra Packages for Enterprise Linux 9 - Next - Testing - x86_64 - Source
epel-testing                                                           Extra Packages for Enterprise Linux 9 - Testing - x86_64
epel-testing-debuginfo                                                 Extra Packages for Enterprise Linux 9 - Testing - x86_64 - Debug
epel-testing-source                                                    Extra Packages for Enterprise Linux 9 - Testing - x86_64 - Source
extras-common                                                          CentOS Stream 9 - Extras packages
remi-modular                                                           Remi's Modular repository for Enterprise Linux 9 - x86_64
remi-safe                                                              Safe Remi's RPM repository for Enterprise Linux 9 - x86_64
zabbix                                                                 Zabbix Official Repository - x86_64
zabbix-non-supported                                                   Zabbix Official Repository non-supported - x86_64

Re: repo not work

So obviously still not there (probably the repo file was removed)

dnf reinstall epel-release


P.S. and enabling epel* doesn't make sense...

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: repo not work

Remi wrote:

So obviously still not there (probably the repo file was removed)

dnf reinstall epel-release


P.S. and enabling epel* doesn't make sense...

dnf reinstall epel-release
Last metadata expiration check: 0:11:07 ago on Wed 27 Sep 2023 05:09:26 PM EEST.
Dependencies resolved.
==============================================================================================================================================================================================
 Package                                         Architecture                              Version                                     Repository                                        Size
==============================================================================================================================================================================================
Reinstalling:
 epel-release                                    noarch                                    9-7.el9                                     extras-common                                     19 k

Transaction Summary
==============================================================================================================================================================================================

Total download size: 19 k
Installed size: 26 k
Is this ok [y/N]: y
Downloading Packages:
epel-release-9-7.el9.noarch.rpm                                                                                                                               264 kB/s |  19 kB     00:00
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                          28 kB/s |  19 kB     00:00
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                                      1/1
  Reinstalling     : epel-release-9-7.el9.noarch                                                                                                                                          1/2
  Running scriptlet: epel-release-9-7.el9.noarch                                                                                                                                          1/2
  Cleanup          : epel-release-9-7.el9.noarch                                                                                                                                          2/2
  Running scriptlet: epel-release-9-7.el9.noarch                                                                                                                                          2/2
  Verifying        : epel-release-9-7.el9.noarch                                                                                                                                          1/2
  Verifying        : epel-release-9-7.el9.noarch                                                                                                                                          2/2

Reinstalled:
  epel-release-9-7.el9.noarch

Complete!
[root@zabbix ~]# dnf config-manager --set-enabled epel
Error: No matching repo to modify: epel.

Re: repo not work

Sorry, I have no idea what wrong with you env.

# rpm -q epel-release
epel-release-9-7.el9.noarch

# dnf repolist
Updating Subscription Management repositories.
Unable to read consumer identity

This system is not registered with an entitlement server. You can use subscription-manager to register.

repo id                                                                                        repo name
appstream                                                                                      CentOS Stream 9 - AppStream
baseos                                                                                         CentOS Stream 9 - BaseOS
crb                                                                                            CentOS Stream 9 - CRB
epel                                                                                           Extra Packages for Enterprise Linux 9 - x86_64
epel-cisco-openh264                                                                            Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64
epel-next                                                                                      Extra Packages for Enterprise Linux 9 - Next - x86_64
extras-common                                                                                  CentOS Stream 9 - Extras packages
packages-microsoft-com-prod                                                                    packages-microsoft-com-prod
remi                                                                                           Remi's RPM repository for Enterprise Linux 9 - x86_64
remi-modular                                                                                   Remi's Modular repository for Enterprise Linux 9 - x86_64
remi-safe                                                                                      Safe Remi's RPM repository for Enterprise Linux 9 - x86_64
rpmfusion-free-updates                                                                         RPM Fusion for EL 9 - Free - Updates

Check the content of /etc/yum.repos.d/epel.repo
if garbage, delete it and reinstall the package to get official version, with "epel" repository config.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: repo not work

Remi wrote:

Sorry, I have no idea what wrong with you env.

# rpm -q epel-release
epel-release-9-7.el9.noarch

# dnf repolist
Updating Subscription Management repositories.
Unable to read consumer identity

This system is not registered with an entitlement server. You can use subscription-manager to register.

repo id                                                                                        repo name
appstream                                                                                      CentOS Stream 9 - AppStream
baseos                                                                                         CentOS Stream 9 - BaseOS
crb                                                                                            CentOS Stream 9 - CRB
epel                                                                                           Extra Packages for Enterprise Linux 9 - x86_64
epel-cisco-openh264                                                                            Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64
epel-next                                                                                      Extra Packages for Enterprise Linux 9 - Next - x86_64
extras-common                                                                                  CentOS Stream 9 - Extras packages
packages-microsoft-com-prod                                                                    packages-microsoft-com-prod
remi                                                                                           Remi's RPM repository for Enterprise Linux 9 - x86_64
remi-modular                                                                                   Remi's Modular repository for Enterprise Linux 9 - x86_64
remi-safe                                                                                      Safe Remi's RPM repository for Enterprise Linux 9 - x86_64
rpmfusion-free-updates                                                                         RPM Fusion for EL 9 - Free - Updates

Check the content of /etc/yum.repos.d/epel.repo
if garbage, delete it and reinstall the package to get official version, with "epel" repository config.

thanks, it worked

dnf remove epel-release
dnf install epel-release
dnf install remi-release
dnf repolist
repo id                                                                repo name
appstream                                                              CentOS Stream 9 - AppStream
baseos                                                                 CentOS Stream 9 - BaseOS
crb                                                                    CentOS Stream 9 - CRB
epel                                                                   Extra Packages for Enterprise Linux 9 - x86_64
epel-cisco-openh264                                                    Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64
epel-next                                                              Extra Packages for Enterprise Linux 9 - Next - x86_64
extras-common                                                          CentOS Stream 9 - Extras packages
remi-modular                                                           Remi's Modular repository for Enterprise Linux 9 - x86_64
remi-safe                                                              Safe Remi's RPM repository for Enterprise Linux 9 - x86_64
zabbix                                                                 Zabbix Official Repository - x86_64
zabbix-non-supported                                                   Zabbix Official Repository non-supported - x86_64