Topic: RockyLinux 9 and php 7.2

I am switching to RockyLinux 9 from CentOS 7 and need to move some old applications to the new servers. These apps require php 7.2 and I have seen that you graciously made php 7.4 for RL 9. I know that php 7.2 is EOL but I still need to keep these web applications running for the foreseeable future.

Would you consider making php 7.2 available for RL 9 as well?

Re: RockyLinux 9 and php 7.2

Sorry, but not planned.

If you need 7.2 you should consider EL-8 which will be supported until 2029
then you have ~5 years to fix your applications to work with newer PHP

PHP 5.6 to 8.3 are available in my repository for EL-8


EL-9 have OpenSSL 3 which is not officially supported by PHP < 8.1
and backporting the needed changes is a huge work.

So only PHP 7.4 to 8.3 are available for newer distro versions.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: RockyLinux 9 and php 7.2

OK, understood. I am planning to skip version 8 of the operating system and then, as you saw, moving from CentOS to RL. I think the best plan is to test if the app will run on php 7.4 which you do offer for RL 9.

Re: RockyLinux 9 and php 7.2

y57ma76yda wrote:

I am switching to RockyLinux 9 from CentOS 7 and need to move some old applications to the new servers. These apps require php 7.2 and I have seen that you graciously made php 7.4 for RL 9. I know that php 7.2 is EOL but I still need to keep these web applications running for the foreseeable future.

Would you consider making php 7.2 available for RL 9 as well?

Old packages can provide any srpm package? Convenient for us to compile our own ?

Re: RockyLinux 9 and php 7.2

> Old packages can provide any srpm package? Convenient for us to compile our own ?

Everything is available in git and in the repo
See the repo home page for links


P.S. but of course, don't expect the build will succeed

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi