1 (edited by jbsegal 2024-01-22 21:26:54)

Topic: [CLOSED] RHEL9 (with SCM+Satellite) - phpunit10 won't install

I'm attempting to get phpunit10 working with php82, both from Remi - and yes, this should Just Work, but...
= = = =

[root@web2 ~]# dnf install phpunit10
Updating Subscription Management repositories.
Remi RHEL9                                              96 kB/s | 2.0 kB     00:00
epel rhel9                                             116 kB/s | 2.3 kB     00:00
MySql_rhel9                                             81 kB/s | 1.7 kB     00:00
Shib_RHEL9                                              98 kB/s | 2.0 kB     00:00
Error:
 Problem: package phpunit10-10.4.2-1.el9.remi.noarch from Remi_RHEL9_Remi_RHEL9 requires php(language) >= 8.1, but none of the providers can be installed
  - cannot install the best candidate for the job
  - package php-common-8.1.8-1.module+el9.1.0+15877+c3862210.x86_64 from rhel-9-for-x86_64-appstream-rpms is filtered out by modular filtering
  - package php-common-8.1.14-1.module+el9.2.0+17911+b059dfc2.x86_64 from rhel-9-for-x86_64-appstream-rpms is filtered out by modular filtering

= = = =

However, 8.2 is already the only thing installed:
= = = =

[root@web2 ~]# rpm -qa | grep php
php82-runtime-8.2-5.el9.remi.x86_64
php82-php-common-8.2.12-1.el9.remi.x86_64
php82-php-pdo-8.2.12-1.el9.remi.x86_64
php82-php-cli-8.2.12-1.el9.remi.x86_64
php82-php-fpm-8.2.12-1.el9.remi.x86_64
php82-php-opcache-8.2.12-1.el9.remi.x86_64
php82-php-xml-8.2.12-1.el9.remi.x86_64
php82-php-sodium-8.2.12-1.el9.remi.x86_64
gd3php-2.3.3-9.el9.remi.x86_64
oniguruma5php-6.9.9-1.el9.remi.x86_64
php82-php-mbstring-8.2.12-1.el9.remi.x86_64
php82-php-intl-8.2.12-1.el9.remi.x86_64
php82-php-8.2.12-1.el9.remi.x86_64
php82-php-pecl-zip-1.22.3-1.el9.remi.x86_64
php82-php-gd-8.2.12-1.el9.remi.x86_64
php82-php-mysqlnd-8.2.12-1.el9.remi.x86_64
php82-php-ldap-8.2.12-1.el9.remi.x86_64
php82-php-soap-8.2.12-1.el9.remi.x86_64
[root@web2 ~]# 

= = = =

I'm installing things via Ansible primarily, but the Wizard here suggests
| dnf module switch-to php:remi-8.2
but that isn't working/found:
= = = =

[root@web2 ~]# dnf module switch-to php:remi-8.2
Updating Subscription Management repositories.
 [ elided ]
Error: Problems in request:
missing groups or modules: php:remi-8.2
[root@web2 ~]#

Note that I'm working via a local (RH-commercial) Satellite server using Simple Content Management, where this repo is mirrored to that server.
I sort of suspect that step is eating the module info?

Thanks in advance for any insights...

Re: [CLOSED] RHEL9 (with SCM+Satellite) - phpunit10 won't install

I think you have mirrored only "remi" repository.
You need "remi-modular"

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: [CLOSED] RHEL9 (with SCM+Satellite) - phpunit10 won't install

For memory, there is 3 repositories

- remi-safe (enabled by default)

safe as "no replacement of official packages" (subset of "remi")

Provides common dependencies (ex: oniguruma5php) and SCLs, designed for parallel installation of various versions (ex: php82-*)

- remi (disabled by default)

May replace some packages (mostly from EPEL)

Provides some PHP app (noarch packages, ex: phpunit*)

- remi-modular (enabled by default)

May replace base packages when a module is explicitly enabled by the administrator

Provides the various PHP stacks (7.4 to 8.3) and other modules

P.S. Updated in the FAQ https://blog.remirepo.net/pages/English-FAQ#layout

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: [CLOSED] RHEL9 (with SCM+Satellite) - phpunit10 won't install

Thanks very much. This got me far enough to find the baseURL for the modular repo, which I then got in to Satellite, along with Safe, together as a new 'product'.

There's ANOTHER problem now, but I'll start a new TL post for that.