Topic: RPM PECL-SQlite

Bonjour,

Je viens vers vous dans l'espoir de trouver une solution à mon problème.
J'ai actuellement un serveur hebergé chez une société de service sur lequel se trouve un bon nombre de pages web et d'applications.
Dans l'optique de me séparer de cette société , je suis en train de créer un serveur dédié en local me permettant de reproduire l'architecture applicative que j'ai actuellement sur le premier.

Le problème c'est que bon nombre des bases de données sont en sqlite2 et en installant apache sur ma machine, je n'arrive pas à les lires.
Je suppose qu'il me faut les drivers sqlite (et non sqlite3) pour php tels que je le voit sur la page phpinfo() du premier serveur.

Ainsi j'ai trouvé ce RPM : http://rpmfind.net//linux/RPM/remi/fedo … .i686.html
Mais je n'arrive pas à l'installer.
Sachant que je suis totalement nouveau sur fedora ( je viens d'un Ubuntu ) , pouvez vous m'indiquer la marche à suivre?

Config :
Apache 2.2.22
PHP 5.4.5

Re: RPM PECL-SQlite

# rpm -ivh php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686.rpm
attention: php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686.rpm: Entête V3 DSA/SHA1 Signature, key ID 00f97f56: NOKEY
erreur: Dépendances requises:
    php(zend-abi) = 20100525-x86-32 est nécessaire pour php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686
    php(api) = 20100412-x86-32 est nécessaire pour php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686
    libc.so.6 est nécessaire pour php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686
    libc.so.6(GLIBC_2.0) est nécessaire pour php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686
    libc.so.6(GLIBC_2.1) est nécessaire pour php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686
    libc.so.6(GLIBC_2.1.3) est nécessaire pour php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686
    libc.so.6(GLIBC_2.2) est nécessaire pour php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686
    libc.so.6(GLIBC_2.3) est nécessaire pour php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686
    libc.so.6(GLIBC_2.3.4) est nécessaire pour php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686
    libc.so.6(GLIBC_2.4) est nécessaire pour php-pecl-sqlite-2.0.0-0.1.svn313074.fc17.remi.i686


Comment installer ces dépendances?

Re: RPM PECL-SQlite

Distro ? version ? arch ?

Ne pas oublier que cette extension est dépréciée depuis pas mal d'années.

Desktop: Fedora 31 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 32 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test