1 (edited by pilote 2010-01-11 20:20:26)

Topic: [résolu] fc8 > update vers php-5.3.1 bloqué

Bonjours,

je viens de tester une mise à jours de php et le processus s'arrête en cours de route...

le contexte
serveur dédié sous fc8 avec plesk et tout le bazard habituel d'un serveur web

je veux passer de php-5.2.6 à php-5.3.1

je configure le dépot remi comme indiqué sur ce blog

wget http://rpms.famillecollet.com/remi-release-8.rpm
rpm -Uvh remi-release-8.rpm

je "check-update php"

[root@srv yum.repos.d]# yum --enablerepo=remi check-update php
remi            | 2.3 kB     00:00     
remi/primary_db        | 222 kB     00:02
php.i386            5.3.1-1.fc8.remi    remi

jusqu'ici tout va bien..
je lance update php tout semble rouler jusqu'à ce que le processus s'arrête...

[root@srv yum.repos.d]# yum --enablerepo=remi update php
Configuration du processus de mise à jour
Résolution des dépendances
--> Lancement de la transaction de test
---> Paquetage php.i386 0:5.3.1-1.fc8.remi marqué pour être mis à jour 
--> Traitement de la dépendance : php-cli = 5.3.1-1.fc8.remi pour le paquetage : php
--> Traitement de la dépendance : php-common = 5.3.1-1.fc8.remi pour le paquetage : php
--> Lancement de la transaction de test
---> Paquetage php-common.i386 0:5.3.1-1.fc8.remi marqué pour être mis à jour 
---> Paquetage php-cli.i386 0:5.3.1-1.fc8.remi marqué pour être mis à jour 
--> Traitement de la dépendance : php-common = 5.2.6-2.fc8 pour le paquetage : php-pdo
--> Traitement de la dépendance : php-common = 5.2.6-2.fc8 pour le paquetage : php-imap
--> Traitement de la dépendance : php-common = 5.2.6-2.fc8 pour le paquetage : php-xml
--> Traitement de la dépendance : php-common = 5.2.6-2.fc8 pour le paquetage : php-mbstring
--> Traitement de la dépendance : php-common = 5.2.6-2.fc8 pour le paquetage : php-gd
--> Traitement de la dépendance : php-common = 5.2.6-2.fc8 pour le paquetage : php-ldap
--> Traitement de la dépendance : php-common = 5.2.6-2.fc8 pour le paquetage : php-mysql
--> Lancement de la transaction de test
---> Paquetage php-mbstring.i386 0:5.3.1-1.fc8.remi marqué pour être mis à jour 
---> Paquetage php-pdo.i386 0:5.3.1-1.fc8.remi marqué pour être mis à jour 
--> Traitement de la dépendance : libsqlite.so.0 pour le paquetage : php-pdo
---> Paquetage php-xml.i386 0:5.3.1-1.fc8.remi marqué pour être mis à jour 
---> Paquetage php-ldap.i386 0:5.3.1-1.fc8.remi marqué pour être mis à jour 
---> Paquetage php-imap.i386 0:5.3.1-1.fc8.remi marqué pour être mis à jour 
---> Paquetage php-gd.i386 0:5.3.1-1.fc8.remi marqué pour être mis à jour 
--> Traitement de la dépendance : libt1.so.5 pour le paquetage : php-gd
---> Paquetage php-mysql.i386 0:5.3.1-1.fc8.remi marqué pour être mis à jour 
--> Traitement de la dépendance : libmysqlclient.so.16 pour le paquetage : php-mysql
--> Traitement de la dépendance : libmysqlclient.so.16(libmysqlclient_16) pour le paquetage : php-mysql
--> Lancement de la transaction de test
---> Paquetage sqlite2.i386 0:2.8.17-2.fc8.remi marqué pour être mis à jour 
--> Traitement de la dépendance : libmysqlclient.so.15 pour le paquetage : mysql-server
--> Traitement de la dépendance : libmysqlclient.so.15 pour le paquetage : ruby-mysql
--> Traitement de la dépendance : libmysqlclient.so.15 pour le paquetage : perl-DBD-MySQL
--> Traitement de la dépendance : libmysqlclient.so.15 pour le paquetage : mysql
--> Traitement de la dépendance : libmysqlclient.so.15 pour le paquetage : psa-mail-qc-driver
--> Traitement de la dépendance : libmysqlclient.so.15 pour le paquetage : psa-backup-manager
--> Traitement de la dépendance : libmysqlclient.so.15 pour le paquetage : psa
--> Traitement de la dépendance : libmysqlclient.so.15 pour le paquetage : psa-mail-driver-common
--> Traitement de la dépendance : libmysqlclient.so.15 pour le paquetage : psa-drweb-configurator
--> Traitement de la dépendance : libmysqlclient.so.15 pour le paquetage : psa-fileserver
--> Traitement de la dépendance : libmysqlclient.so.15(libmysqlclient_15) pour le paquetage : mysql-server
--> Traitement de la dépendance : libmysqlclient.so.15(libmysqlclient_15) pour le paquetage : ruby-mysql
--> Traitement de la dépendance : libmysqlclient.so.15(libmysqlclient_15) pour le paquetage : perl-DBD-MySQL
--> Traitement de la dépendance : libmysqlclient.so.15(libmysqlclient_15) pour le paquetage : mysql
--> Traitement de la dépendance : libmysqlclient.so.15(libmysqlclient_15) pour le paquetage : psa-mail-qc-driver
--> Traitement de la dépendance : libmysqlclient.so.15(libmysqlclient_15) pour le paquetage : psa-drweb-configurator
--> Traitement de la dépendance : libmysqlclient.so.15(libmysqlclient_15) pour le paquetage : psa-fileserver
--> Traitement de la dépendance : libmysqlclient_r.so.15 pour le paquetage : mysql-server
--> Traitement de la dépendance : libmysqlclient_r.so.15(libmysqlclient_15) pour le paquetage : mysql-server
--> Traitement de la dépendance : mysql-libs = 5.0.45-6.fc8 pour le paquetage : mysql
---> Paquetage mysql-libs.i386 0:5.1.42-1.fc8.remi marqué pour être mis à jour 
---> Paquetage t1lib.i386 0:5.1.1-7.fc8 marqué pour être mis à jour 
--> Traitement de la dépendance : libXaw.so.7 pour le paquetage : t1lib
--> Lancement de la transaction de test
---> Paquetage libXaw.i386 0:1.0.4-1.fc8 marqué pour être mis à jour 
--> Traitement de la dépendance : libXmu.so.6 pour le paquetage : libXaw
---> Paquetage mysql.i386 0:5.1.42-1.fc8.remi marqué pour être mis à jour 
---> Paquetage mysqlclient15.i386 0:5.0.67-1.fc8.remi marqué pour être mis à jour 
---> Paquetage mysql-server.i386 0:5.1.42-1.fc8.remi marqué pour être mis à jour 
--> Lancement de la transaction de test
---> Paquetage libXmu.i386 0:1.0.3-3.fc8 marqué pour être mis à jour 
remi/filelists_db            | 550 kB     00:05     
updates-newkey/filelists_db            | 6.9 MB     01:35     
fedora/filelists_db            | 8.0 MB     01:50   

voila après cela.. Rien.. mom php-5.2.6 est toujours là et refuse de laisser sa place

pour info le php et ses petits actuellement installé

[root@srv /]# rpm -qa | grep php
php-common-5.2.6-2.fc8
php-pdo-5.2.6-2.fc8
php-mysql-5.2.6-2.fc8
php-cli-5.2.6-2.fc8
php-mbstring-5.2.6-2.fc8
php-pear-DB-1.7.13-1.fc8
php-pear-Auth-SASL-1.0.2-4.fc6
php-pear-Mail-Mime-1.5.2-3.fc8
php-imap-5.2.6-2.fc8
php-xml-5.2.6-2.fc8
php-pear-1.6.2-2.fc8
php-pear-File-1.3.0-1.fc8
php-pear-Net-Socket-1.0.9-1.fc8
php-pear-Net-SMTP-1.3.2-1.fc8
php-pear-Log-1.11.3-1.fc8
php-pear-Mail-mimeDecode-1.5.0-3.fc8
psa-php5-configurator-1.5.1-fc8.build90090127.18
php-5.2.6-2.fc8
php-ldap-5.2.6-2.fc8
php-gd-5.2.6-2.fc8
php-pear-MDB2-2.4.1-2.fc8
php-pear-Mail-1.1.14-2.fc8

je pourrais certes upgrader fc8 jusqu'à une version actuelle
mais je crains de tout bousiller sans même comprendre comment.

déjà que je rame pour un simple up. de php

si quelqu'un a une piste
qu'il soit le bienvenus

Re: [résolu] fc8 > update vers php-5.3.1 bloqué

Ben.. je vois pas d'erreur...

Il est juste en cours de téléchargement des dépôts, et les dépôts F8 ne sont pas trop courant.

A vérifier si l'adresse de tous les dépôts fonctionne

yum clean all
yum repolist
yum update

+

Desktop: Fedora 29 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 30 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: [résolu] fc8 > update vers php-5.3.1 bloqué

Il est juste en cours de téléchargement des dépôts...

ouaip.. sans doute un problème d'accès à ce moment là
j'ai laissé tourner longtemps avant de me dire qu'il y avait un réel bloquage

je viens de relancer la manip. ; mise à jour nickel -> sans aucun bloquage ;

je suis ravi :-)

merci et bravo pour ces précieuses ressources