Topic: firefox-24.0-1.el6.remi.x86_64 / remi-release-6

Hi,

We have tested our environment with the version firefox 24. To avoid a new validation process I need the version 24 but in remi-release-6 only version 25 is offered.

To answer your questions:
1. Yes, I have read and do understand the disclaimer
2. OS is RHEL 6.4
3. x86_64
4. the package is firefox-24.0-1.el6.remi.x86_64 and of course xulrunner-last-24.0-1.el6.remi.x86_64


Thank you in advance

Re: firefox-24.0-1.el6.remi.x86_64 / remi-release-6

See Remi repository temporary upload space

Remi.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: firefox-24.0-1.el6.remi.x86_64 / remi-release-6

Thank you very much!

You have saved me a lot of work!

Cheers
kris

Re: firefox-24.0-1.el6.remi.x86_64 / remi-release-6

Hi Remi,

sorry for bother you again but there are more dependencies I'm not aware before.

Could you provide me your package which my predecessor fetched?

> 2013-10-28 15:38:44 rpm -Uvh http://rpms.famillecollet.com/enterpris … ease-6.rpm

Thank you in advance.

Kris

Re: firefox-24.0-1.el6.remi.x86_64 / remi-release-6

This is still online:
http://rpms.famillecollet.com/enterpris … lease.html

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

6 (edited by kris 2013-11-21 12:29:04)

Re: firefox-24.0-1.el6.remi.x86_64 / remi-release-6

Hi Remi,

after installing the remi-release-6 I got offered firefox 25.

And if I use the 24 packages package trying to install firefox 24
the dependency problems are not solved. I tought this were done by this package.

For example on the first machine where firefox 24 is running the glibc 2.12 is installed.
On the new machine I can't install xulrunner 24 because it depends on glib 2.14.

Similar problems to the dependencies of the following packages:
- nss
- nspr
- libstdc++
- libhunspell
- libsmime3
- libvpx

Maybe my predecessor have done some mystic rpm stuff. But I'm aware of it.

If you could help me this would be great.

Cheers
Kris

Re: firefox-24.0-1.el6.remi.x86_64 / remi-release-6

Please, post the full yum command output.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: firefox-24.0-1.el6.remi.x86_64 / remi-release-6

[root@bs-ci03:~[1]# yum install xulrunner-24.0-2.fc18.x86_64.rpm
Loaded plugins: product-id, refresh-packagekit, rhnplugin, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Examining xulrunner-24.0-2.fc18.x86_64.rpm: xulrunner-24.0-2.fc18.x86_64
Marking xulrunner-24.0-2.fc18.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package xulrunner.x86_64 0:24.0-2.fc18 will be installed
--> Processing Dependency: nspr >= 4.10.0 for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: nss >= 3.15.1 for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: libsmime3.so(NSS_3.15)(64bit) for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: libhunspell-1.3.so.0()(64bit) for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: libvpx.so.1()(64bit) for package: xulrunner-24.0-2.fc18.x86_64
--> Running transaction check
---> Package xulrunner.x86_64 0:24.0-2.fc18 will be installed
--> Processing Dependency: nspr >= 4.10.0 for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: nss >= 3.15.1 for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.15)(64bit) for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: libhunspell-1.3.so.0()(64bit) for package: xulrunner-24.0-2.fc18.x86_64
--> Processing Dependency: libvpx.so.1()(64bit) for package: xulrunner-24.0-2.fc18.x86_64
---> Package xulrunner-last.x86_64 0:24.0-1.el6.remi will be installed
--> Finished Dependency Resolution
Error: Package: xulrunner-24.0-2.fc18.x86_64 (/xulrunner-24.0-2.fc18.x86_64)
           Requires: nss >= 3.15.1
           Installed: nss-3.14.3-4.el6_4.x86_64 (@rhel-x86_64-server-6)
               nss = 3.14.3-4.el6_4
           Available: nss-3.12.7-2.el6.i686 (rhel-x86_64-server-6)
               nss = 3.12.7-2.el6
           Available: nss-3.12.8-1.el6_0.i686 (rhel-x86_64-server-6)
               nss = 3.12.8-1.el6_0
           Available: nss-3.12.8-3.el6_0.i686 (rhel-x86_64-server-6)
               nss = 3.12.8-3.el6_0
           Available: nss-3.12.9-9.el6.i686 (rhel-x86_64-server-6)
               nss = 3.12.9-9.el6
           Available: nss-3.12.9-12.el6_1.i686 (rhel-x86_64-server-6)
               nss = 3.12.9-12.el6_1
           Available: nss-3.12.10-2.el6_1.i686 (rhel-x86_64-server-6)
               nss = 3.12.10-2.el6_1
           Available: nss-3.12.10-16.el6.i686 (rhel-x86_64-server-6)
               nss = 3.12.10-16.el6
           Available: nss-3.12.10-17.el6_2.i686 (rhel-x86_64-server-6)
               nss = 3.12.10-17.el6_2
           Available: nss-3.13.1-6.el6_2.i686 (rhel-x86_64-server-6)
               nss = 3.13.1-6.el6_2
           Available: nss-3.13.1-7.el6_2.i686 (rhel-x86_64-server-6)
               nss = 3.13.1-7.el6_2
           Available: nss-3.13.3-6.el6.i686 (rhel-x86_64-server-6)
               nss = 3.13.3-6.el6
           Available: nss-3.13.3-8.el6.i686 (rhel-x86_64-server-6)
               nss = 3.13.3-8.el6
           Available: nss-3.13.5-1.el6_3.i686 (rhel-x86_64-server-6)
               nss = 3.13.5-1.el6_3
           Available: nss-3.13.6-2.el6_3.i686 (rhel-x86_64-server-6)
               nss = 3.13.6-2.el6_3
           Available: nss-3.14.0.0-12.el6.i686 (rhel-x86_64-server-6)
               nss = 3.14.0.0-12.el6
Error: Package: xulrunner-24.0-2.fc18.x86_64 (/xulrunner-24.0-2.fc18.x86_64)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: xulrunner-24.0-2.fc18.x86_64 (/xulrunner-24.0-2.fc18.x86_64)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: xulrunner-24.0-2.fc18.x86_64 (/xulrunner-24.0-2.fc18.x86_64)
           Requires: nspr >= 4.10.0
           Installed: nspr-4.9.5-2.el6_4.x86_64 (@rhel-x86_64-server-6)
               nspr = 4.9.5-2.el6_4
           Available: nspr-4.8.6-1.el6.i686 (rhel-x86_64-server-6)
               nspr = 4.8.6-1.el6
           Available: nspr-4.8.7-1.el6.i686 (rhel-x86_64-server-6)
               nspr = 4.8.7-1.el6
           Available: nspr-4.8.8-1.el6_1.i686 (rhel-x86_64-server-6)
               nspr = 4.8.8-1.el6_1
           Available: nspr-4.8.8-3.el6.i686 (rhel-x86_64-server-6)
               nspr = 4.8.8-3.el6
           Available: nspr-4.8.9-3.el6_2.i686 (rhel-x86_64-server-6)
               nspr = 4.8.9-3.el6_2
           Available: nspr-4.9-1.el6.i686 (rhel-x86_64-server-6)
               nspr = 4.9-1.el6
           Available: nspr-4.9.1-2.el6_3.i686 (rhel-x86_64-server-6)
               nspr = 4.9.1-2.el6_3
           Available: nspr-4.9.2-0.el6_3.1.i686 (rhel-x86_64-server-6)
               nspr = 4.9.2-0.el6_3.1
           Available: nspr-4.9.2-1.el6.i686 (rhel-x86_64-server-6)
               nspr = 4.9.2-1.el6
Error: Package: xulrunner-24.0-2.fc18.x86_64 (/xulrunner-24.0-2.fc18.x86_64)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: xulrunner-24.0-2.fc18.x86_64 (/xulrunner-24.0-2.fc18.x86_64)
           Requires: libhunspell-1.3.so.0()(64bit)
Error: Package: xulrunner-24.0-2.fc18.x86_64 (/xulrunner-24.0-2.fc18.x86_64)
           Requires: libvpx.so.1()(64bit)
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
1:eclipse-swt-3.6.1-6.13.el6.x86_64 has missing requires of xulrunner >= ('0', '1.9', None)
yelp-2.28.1-17.el6_3.x86_64 has missing requires of gecko-libs >= ('0', '17.0', None)
[root@bs-ci03:~[1]#

Re: firefox-24.0-1.el6.remi.x86_64 / remi-release-6

xulrunner-24.0-2.fc18.x86_64.rpm is not my package (xulrunnner-last).
You are trying to install a Fedora 18 package on EL-6. This could not work.

Laptop:  Fedora 40 + rpmfusion + remi (SCL only)
x86_64 builder: Fedora 39 + rpmfusion + remi-test
aarch64 builder: RHEL 9 with EPEL
Hosting Server: AlmaLinux 8 with EPEL, rpmfusion, remi

Re: firefox-24.0-1.el6.remi.x86_64 / remi-release-6

Sorry for my stupid error, using tab completion and not looking in detail is not a good option.

Your packages installed as expected.

Sorry for bothering you.

And of course thank you for your patient and work.

cheers
Kris