1 (edited by andykimpe 2014-02-27 05:14:28)

Topic: andykimpe (Zpanel Teams) Présentation

Bonsoir a tous.

Je m’appelle Andy Kimpe d’où mon pseudo andykimpe.

J'ai 22 ans et j'habite Roubaix dans le Nord pas de Calais.

Je suis apprentie développeurs,

Administrateur de la communauté francophone de zpanel

Et membre de la Quality Assurance de zpanel (QA)

Je me suis inscrit ici car je pense que c'est le meilleurs endroit pour demander de l'aide sur la gestion de dépôt rpm pour serveur dédier.

Et plus particulièrement les prérequis de zpanel apache, php, suhosin, proftpd, dovecot, postfix, named, mysql et atd.

Ma première question.

A ton le droit de tutoyer sur ce forum (personnellement je trouve ça plus amical).

Ou doit ont utiliser le vouvoiement ?

Deuxième question.

J'ai déjà pour l'instant créer un dépôt pour Centos 6.

D'autre dépôt seront créer pour Fédora 17, 18, 19 et 20.

Ce dépôt fonctionne avec createrepo-0.9.9-18.el6.noarch mais il semble y avoir un bug

A chaque fois que ont modifie le dépôt il faut toujours faire.

sudo yum clean all

Il y a t'il quelle que chose de mien que createrepo ?

Ou doit ton utiliser des paramètre spécifique pour qu'il fonctionne correctement

Pour l'instant s'utilise

createrepo $HOME/rpmbuild/RPMS/x86_64
createrepo --update $HOME/rpmbuild/RPMS/x86_64

Troisième question. (bien que sa serait plus tôt une requête.)

Zpanel étant un produit open source nous man-qu’ont de personnelle qualifier.

Es ce que vous Remi ou une personne qualifier pourrait prendre la gestion des dépôts.

Je préférée me concentrée sur le développement du panel plutôt que de passer mon temps a gérée les dépôts.

je ne suis pas du genre a demander sans rien donnée en retour

la personne qui acceptera recevra

un espace de stockage illimitée sur mon hébergement 1 and 1

Dans votre cas Remi sa pourrait vous permétre de faire un miroir supplémentaire pour vos dépôt

Un VPS KVM (chez online) pour le développement et la gestion des dépôts.

Re: andykimpe (Zpanel Teams) Présentation

> A ton le droit de tutoyer sur ce forum (personnellement je trouve ça plus amical).
Le "tu" me convient parfaitement

> Il y a t'il quelle que chose de mien que createrepo ?
Non

> A chaque fois que ont modifie le dépôt il faut toujours faire.
Normal, il faut attendre l'expiration des metadata.

Astuce: régler la valeur de metadata_expire (perso, en local, pour tester mon dépôt, j'utilise 1)

> Es ce que vous Remi ou une personne qualifier pourrait prendre la gestion des dépôts.
Désolé, mais j'ai déjà largement trop de boulot uniquement avec la pile PHP.

Mais une solution simple, justement prévu pour les "upstream" c'est d'utiliser Copr.
http://copr.fedoraproject.org/

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

3 (edited by andykimpe 2014-02-27 22:26:14)

Re: andykimpe (Zpanel Teams) Présentation

Ok pour les metadata j'ai vu c'est dans la de config de yum

Il faudrait donc que j'ajoute ceci dans le postinstall du pacquet.

zpanel-release

%pre
rm -f /etc/yum.repos.d/*

%post
mv /etc/yum.repos.d/CentOS-Base.repo.zp /etc/yum.repos.d/CentOS-Base.repo
mv /etc/yum.repos.d/CentOS-Debuginfo.repo.zp /etc/yum.repos.d/CentOS-Debuginfo.repo
mv /etc/yum.repos.d/CentOS-Media.repo.zp /etc/yum.repos.d/CentOS-Media.repo
mv /etc/yum.repos.d/CentOS-Vault.repo.zp /etc/yum.repos.d/CentOS-Vault.repo
sed -i 's/# metadata_expire=90m/metadata_expire=1/g' "/etc/yum.conf"

pour copr sa ma l'air un peut comme les ppa a moins que je trompe

et je c'est que ballen
(Bobby Allen chef du projet zpanel) n'ai pas pour l'utilisation de dépôt externe

ont as eu quelle problème avec annonymous a cause de sa entre autre

l'année dernière.

pour le boulot je te comprend ont est un peut dans le cas de ce coté.

une petite dernière question

sait tu comment ont pourrais faire un version portable de php il me semble que le nom exacte serait version lamp

a savoir que nous installons zpanel avec les pacquets

php php-suhosin php-devel php-gd php-mbstring php-mcrypt php-intl php-imap php-mysql php-xml php-xmlrpc

il faudrait également que toutes les dépendance soit compiler dans le prefix

et que sa puisse une fois compiler être compatible sur tous les système unix

y compris mac

comme par exemple pour la version Windows qui va être abandonner après la prochaine version de zpanel

notre installateur actuel et compatible avec les version

xp, SP3 vista, 7, 8 server 2008, server 2012

Re: andykimpe (Zpanel Teams) Présentation

> sed -i 's/# metadata_expire=90m/metadata_expire=1/g' "/etc/yum.conf"

Aucun intérêt.
ça a du sens de le faire pour "tester" un dépôt local. Pour un dépôt en ligne, c'est juste générer du trafic inutile, la valeur de 90m est largement suffisante.

> pour copr sa ma l'air un peut comme les ppa a moins que je trompe

Oui.
C'est la mise à disposition de "builder" pour les upstream.
Après, rien n'interdit de récupérer les paquets générés et de les distribuer autrement.

> sait tu comment ont pourrais faire un version portable de php il me semble que le nom exacte serait version lamp

C'est juste irréaliste, et, IMHO, ridicule et sans intérêt.
Les distributions linux founissent un pile LAMP qu'il serait dommage de ne pas utiliser.

Le boulot de "packageur", c'est justement de gérer l'intégration des composants dans un tout cohérent (la distribution).

Réinventer la roue pour fournir une autre pile, et juste un énorme gaspillage d'énergie.
Surtout que maintenir la stabilité et la sécurité est quelque chose de très couteux (temps, ressources) et qu'en dehors des grosses distributions (comme Red Hat), ça me semble clairement injustifié.

D'ailleurs les autres "panel" font des choses similaires, si bien que les supports communautaires des distributions refusent généralement d'aider les utilisateurs de ces outils qui modifient la distribution en profondeur et en font quelque chose de totalement différent.


Après, ce forum est dédié à l'assistance pour l'utilisation de mon dépôt.
Je peux aider, mais là, ça dépasse largement ce que je peux faire sans pénaliser mes autres activités.

Remi.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 24 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.8 x86_64 + EPEL + remi + remi-php70

Re: andykimpe (Zpanel Teams) Présentation

ok je comprend ton résonnement dans ce cas il faut mien je continue a faire comme je l'ai fait pour centos

tout au moins pour fédora surtout la version 20 qui fournie par défaut php 5.5 qui n'est pas compatible avec suhosin

pour centos j'ai recompiler les rpm en les renomment en zpphp au lieu de php

Depot zpanel base

zpphp-5.3.3-27.el6.src.rpm

zpphp-suhosin-0.9.29-2.el6.src.rpm

depot zpanel php54

zpphp-5.4.25-31.art.src.rpm

zpphp-suhosin-0.9.33-2.git1fba865.art.src.rpm

ici j'ai pris les rpm de atomicorp c'est le seul dépôt ou j'ai réussie a trouver suhosin 0.34-dev

il ne semble y avoir aucun bug

je croit que je vais faire pareil avec fédora

fédora 16 php-5.3.8-3.fc16.src.rpm

fédora 15 php-suhosin-0.9.32.1-2.fc15.src.rpm

fédora 18 php-5.4.9-1.fc18.src.rpm

zphp-suhosin version centos

bon je vais tester sa, jarrète avec mes question