Topic: more-php56-php-pecl-memcached-2.2.0-6 missing depedency

It seems rpmbuild didn't pick up the dependency on fastlz for more-php56-php-pecl-memcached-2.2.0-6.el6.x86_64

Installing : more-php56-php-pecl-memcached-2.2.0-6.el6.x86_64
PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/rh/rh-php56/root/usr/lib64/php/modules/memcached.so' 
- libfastlz.so.0: cannot open shared object file: No such file or directory in Unknown on line 0

# repoquery --requires --resolve more-php56-php-pecl-memcached-2.2.0-6.el6.x86_64
more-php56-php-pecl-memcached-0:2.2.0-6.el6.x86_64
bash-0:4.1.2-33.el6.x86_64
more-php56-php-pecl-igbinary-0:1.2.1-2.el6.5.6.x86_64
more-php56-libmemcached-libs-0:1.0.18-5.el6.x86_64
more-php56-php-pecl-msgpack-0:0.5.6-2.el6.5.6.x86_64
rh-php56-php-common-0:5.6.5-7.el6.x86_64
rh-php56-php-pecl-jsonc-0:1.3.6-3.el6.x86_64
more-php56-libevent-0:2.0.22-2.el6.x86_64
# ldd /opt/rh/rh-php56/root/usr/lib64/php/modules/memcached.so 
    linux-vdso.so.1 =>  (0x00007ffc2bff8000)
    libmemcachedprotocol.so.0 => /opt/rh/rh-php56/root/usr/lib64/libmemcachedprotocol.so.0 (0x00007fd16fadf000)
    libz.so.1 => /lib64/libz.so.1 (0x00007fd16f8c4000)
    libmemcached.so.11 => /opt/rh/rh-php56/root/usr/lib64/libmemcached.so.11 (0x00007fd16f692000)
    libmemcachedutil.so.2 => /opt/rh/rh-php56/root/usr/lib64/libmemcachedutil.so.2 (0x00007fd16f48e000)
    libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x00007fd16f273000)
    libfastlz.so.0 => not found
    libevent-2.0.so.5 => /opt/rh/rh-php56/root/usr/lib64/libevent-2.0.so.5 (0x00007fd16f02d000)
    libc.so.6 => /lib64/libc.so.6 (0x00007fd16ec98000)
    libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fd16ea7b000)
    libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007fd16e775000)
    libm.so.6 => /lib64/libm.so.6 (0x00007fd16e4f0000)
    libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fd16e2da000)
    libdl.so.2 => /lib64/libdl.so.2 (0x00007fd16e0d6000)
    libresolv.so.2 => /lib64/libresolv.so.2 (0x00007fd16debb000)
    libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007fd16dc84000)
    librt.so.1 => /lib64/librt.so.1 (0x00007fd16da7c000)
    /lib64/ld-linux-x86-64.so.2 (0x00007fd16ff04000)
    libfreebl3.so => /lib64/libfreebl3.so (0x00007fd16d878000)

Re: more-php56-php-pecl-memcached-2.2.0-6 missing depedency

Thanks for the report.

Can you try to yum install "fastlz" (from EPEL) ?

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: more-php56-php-pecl-memcached-2.2.0-6 missing depedency

Installing fastlz adds the missing library.  I guess maybe the spec needs a BuildRequires so that it gets pulled in by yum?

Re: more-php56-php-pecl-memcached-2.2.0-6 missing depedency

Fixed in https://github.com/remicollet/remirepo/ … 6c423d3de6
Build: https://copr.fedoraproject.org/coprs/re … ld/108386/

2.2.0-7 should be available soon on https://www.softwarecollections.org/en/ (after the next sync)

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: more-php56-php-pecl-memcached-2.2.0-6 missing depedency

Thank you!