Topic: Installing php 5.6 on centos 6

Hi,
I have problem on updating php 5.3.3. to php5.6 on Centos 6.5.
I don't know why but on update yum is trying to use packages of el7 not 6 (line like: ---> Package php-gd.x86_64 0:5.6.32-1.el7.remi will be an update). I don't have any repositoris for el7 active
Please help.
P.S. (I'v changed "httpd" to htt-pd, because forum was detecting it as links and there can by only one in post...)

[root@zabbix remi]#yum -update php*
Loaded plugins: fastestmirror
Setting up Update Process
Examining php-5.6.32-1.el6.remi.x86_64.rpm: php-5.6.32-1.el6.remi.x86_64
Marking php-5.6.32-1.el6.remi.x86_64.rpm as an update to php-5.3.3-49.el6.x86_64
Loading mirror speeds from cached hostfile
* base: mirror-pl kielcetechnologypark net
* epel: mirror de leaseweb net
* extras: mirror-pl kielcetechnologypark net
* remi: mirror 23media de
* remi-php56: mirror.23media de
* updates: mirror-pl kielcetechnologypark net
remi-php54                                                                                                                                                                    | 2.9 kB     00:00
remi-php54/primary_db                                                                                                                                                         | 194 kB     00:00
Examining php-bcmath-5.6.32-1.el6.remi.x86_64.rpm: php-bcmath-5.6.32-1.el6.remi.x86_64
Marking php-bcmath-5.6.32-1.el6.remi.x86_64.rpm as an update to php-bcmath-5.3.3-49.el6.x86_64
Examining php-cli-5.6.32-1.el6.remi.x86_64.rpm: php-cli-5.6.32-1.el6.remi.x86_64
Marking php-cli-5.6.32-1.el6.remi.x86_64.rpm as an update to php-cli-5.3.3-49.el6.x86_64
Examining php-common-5.6.32-1.el6.remi.x86_64.rpm: php-common-5.6.32-1.el6.remi.x86_64
Marking php-common-5.6.32-1.el6.remi.x86_64.rpm as an update to php-common-5.3.3-49.el6.x86_64
Examining php-devel-5.6.32-1.el6.remi.x86_64.rpm: php-devel-5.6.32-1.el6.remi.x86_64
Package php-devel not installed, cannot update it. Run yum install to install it instead.
Examining php-mbstring-5.6.32-1.el6.remi.x86_64.rpm: php-mbstring-5.6.32-1.el6.remi.x86_64
Marking php-mbstring-5.6.32-1.el6.remi.x86_64.rpm as an update to php-mbstring-5.3.3-49.el6.x86_64
Examining php-pdo-5.6.32-1.el6.remi.x86_64.rpm: php-pdo-5.6.32-1.el6.remi.x86_64
Marking php-pdo-5.6.32-1.el6.remi.x86_64.rpm as an update to php-pdo-5.3.3-49.el6.x86_64
Examining php-pear-1.10.5-2.el6.remi.noarch.rpm: 1:php-pear-1.10.5-2.el6.remi.noarch
Package php-pear not installed, cannot update it. Run yum install to install it instead.
Examining php-pecl-jsonc-1.3.10-2.el6.remi.5.6.x86_64.rpm: php-pecl-jsonc-1.3.10-2.el6.remi.5.6.x86_64
Package php-pecl-jsonc not installed, cannot update it. Run yum install to install it instead.
Examining php-pecl-jsonc-devel-1.3.10-2.el6.remi.5.6.x86_64.rpm: php-pecl-jsonc-devel-1.3.10-2.el6.remi.5.6.x86_64
Package php-pecl-jsonc-devel not installed, cannot update it. Run yum install to install it instead.
Examining php-pecl-zip-1.15.1-1.el6.remi.5.6.x86_64.rpm: php-pecl-zip-1.15.1-1.el6.remi.5.6.x86_64
Cannot install package php-pecl-zip-1.15.1-1.el6.remi.5.6.x86_64. It is obsoleted by installed package php-common-5.3.3-49.el6.x86_64
Examining php-tidy-5.6.32-1.el6.remi.x86_64.rpm: php-tidy-5.6.32-1.el6.remi.x86_64
Package php-tidy not installed, cannot update it. Run yum install to install it instead.
Examining php-xml-5.6.32-1.el6.remi.x86_64.rpm: php-xml-5.6.32-1.el6.remi.x86_64
Marking php-xml-5.6.32-1.el6.remi.x86_64.rpm as an update to php-xml-5.3.3-49.el6.x86_64
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.3.3-49.el6 will be updated
---> Package php.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php-bcmath.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-bcmath.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php-cli.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-cli.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php-common.x86_64 0:5.3.3-49.el6 will be updated
--> Processing Dependency: php-common(x86-64) = 5.3.3-49.el6 for package: php-process-5.3.3-49.el6.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-49.el6 for package: php-gd-5.3.3-49.el6.x86_64
--> Processing Dependency: php-common(x86-64) = 5.3.3-49.el6 for package: php-mysql-5.3.3-49.el6.x86_64
---> Package php-common.x86_64 0:5.6.32-1.el6.remi will be an update
--> Processing Dependency: php-pecl-jsonc(x86-64) for package: php-common-5.6.32-1.el6.remi.x86_64
--> Processing Dependency: php-pecl-zip(x86-64) for package: php-common-5.6.32-1.el6.remi.x86_64
---> Package php-mbstring.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-mbstring.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php-pdo.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-pdo.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php-xml.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-xml.x86_64 0:5.6.32-1.el6.remi will be an update
--> Running transaction check
---> Package php-gd.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-gd.x86_64 0:5.6.32-1.el7.remi will be an update
--> Processing Dependency: php-common(x86-64) = 5.6.32-1.el7.remi for package: php-gd-5.6.32-1.el7.remi.x86_64
--> Processing Dependency: libt1.so.5()(64bit) for package: php-gd-5.6.32-1.el7.remi.x86_64
--> Processing Dependency: libpng15.so.15()(64bit) for package: php-gd-5.6.32-1.el7.remi.x86_64
---> Package php-mysql.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-mysql.x86_64 0:5.4.45-13.el7.remi will be an update
--> Processing Dependency: php-pdo(x86-64) = 5.4.45-13.el7.remi for package: php-mysql-5.4.45-13.el7.remi.x86_64
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_18)(64bit) for package: php-mysql-5.4.45-13.el7.remi.x86_64
--> Processing Dependency: libmysqlclient.so.18()(64bit) for package: php-mysql-5.4.45-13.el7.remi.x86_64
---> Package php-pecl-jsonc.x86_64 0:1.3.10-2.el7.remi.5.6 will be installed
---> Package php-pecl-zip.x86_64 0:1.15.1-1.el7.remi.5.6 will be installed
--> Processing Dependency: libzip.so.5()(64bit) for package: php-pecl-zip-1.15.1-1.el7.remi.5.6.x86_64
---> Package php-process.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-process.x86_64 0:5.6.32-1.el7.remi will be an update
--> Running transaction check
---> Package compat-mysql55.x86_64 0:5.5.55-1.el6.remi will be installed
---> Package libzip5.x86_64 0:1.3.0-1.el7.remi will be installed
---> Package php.x86_64 0:5.3.3-49.el6 will be updated
---> Package php.x86_64 0:5.3.3-49.el6 will be updated
---> Package php.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php.x86_64 0:5.6.32-1.el7.remi will be an update
--> Processing Dependency: htt-pd-mmn = 20120211x8664 for package: php-5.6.32-1.el7.remi.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-5.6.32-1.el7.remi.x86_64
--> Processing Dependency: libpcre.so.1()(64bit) for package: php-5.6.32-1.el7.remi.x86_64
---> Package php-bcmath.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-bcmath.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-bcmath.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php-bcmath.x86_64 0:5.6.32-1.el7.remi will be an update
---> Package php-cli.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-cli.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-cli.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php-cli.x86_64 0:5.6.32-1.el7.remi will be an update
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: php-cli-5.6.32-1.el7.remi.x86_64
--> Processing Dependency: libpcre.so.1()(64bit) for package: php-cli-5.6.32-1.el7.remi.x86_64
---> Package php-common.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-common.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-common.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php-common.x86_64 0:5.6.32-1.el7.remi will be an update
---> Package php-gd.x86_64 0:5.6.32-1.el7.remi will be an update
--> Processing Dependency: libpng15.so.15()(64bit) for package: php-gd-5.6.32-1.el7.remi.x86_64
---> Package php-mbstring.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-mbstring.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-mbstring.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php-mbstring.x86_64 0:5.6.32-1.el7.remi will be an update
---> Package php-mysql.x86_64 0:5.4.45-13.el7.remi will be an update
--> Processing Dependency: php-pdo(x86-64) = 5.4.45-13.el7.remi for package: php-mysql-5.4.45-13.el7.remi.x86_64
---> Package php-pdo.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-pdo.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-pdo.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php-pdo.x86_64 0:5.6.32-1.el7.remi will be an update
---> Package php-xml.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-xml.x86_64 0:5.3.3-49.el6 will be updated
---> Package php-xml.x86_64 0:5.6.32-1.el6.remi will be an update
---> Package php-xml.x86_64 0:5.6.32-1.el7.remi will be an update
--> Processing Dependency: libxml2.so.2(LIBXML2_2.9.0)(64bit) for package: php-xml-5.6.32-1.el7.remi.x86_64
---> Package t1lib.x86_64 0:5.1.2-6.el6_2.1 will be installed
--> Finished Dependency Resolution
Error: Package: php-mysql-5.4.45-13.el7.remi.x86_64 (remi)
           Requires: php-pdo(x86-64) = 5.4.45-13.el7.remi
           Removing: php-pdo-5.3.3-49.el6.x86_64 (@base)
               php-pdo(x86-64) = 5.3.3-49.el6
           Updated By: php-pdo-5.6.32-1.el7.remi.x86_64 (remi-php56)
               php-pdo(x86-64) = 5.6.32-1.el7.remi
           Available: php-pdo-5.3.2-6.el6.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.2-6.el6
           Available: php-pdo-5.3.2-6.el6_0.1.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.2-6.el6_0.1
           Available: php-pdo-5.3.3-3.el6.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-3.el6
           Available: php-pdo-5.3.3-3.el6_1.3.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-3.el6_1.3
           Available: php-pdo-5.3.3-3.el6_2.5.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-3.el6_2.5
           Available: php-pdo-5.3.3-3.el6_2.6.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-3.el6_2.6
           Available: php-pdo-5.3.3-3.el6_2.8.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-3.el6_2.8
           Available: php-pdo-5.3.3-14.el6_3.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-14.el6_3
           Available: php-pdo-5.3.3-22.el6.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-22.el6
           Available: php-pdo-5.3.3-23.el6_4.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-23.el6_4
           Available: php-pdo-5.3.3-26.el6.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-26.el6
           Available: php-pdo-5.3.3-27.el6_5.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-27.el6_5
           Available: php-pdo-5.3.3-27.el6_5.1.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-27.el6_5.1
           Available: php-pdo-5.3.3-27.el6_5.2.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-27.el6_5.2
           Available: php-pdo-5.3.3-38.el6.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-38.el6
           Available: php-pdo-5.3.3-40.el6_6.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-40.el6_6
           Available: php-pdo-5.3.3-46.el6_6.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-46.el6_6
           Available: php-pdo-5.3.3-46.el6_7.1.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-46.el6_7.1
           Available: php-pdo-5.3.3-47.el6.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-47.el6
           Available: php-pdo-5.3.3-48.el6_8.x86_64 (ol6_latest)
               php-pdo(x86-64) = 5.3.3-48.el6_8
           Available: php-pdo-5.4.45-12.el6.remi.x86_64 (remi-php54)
               php-pdo(x86-64) = 5.4.45-12.el6.remi
           Available: php-pdo-5.4.45-13.el6.remi.x86_64 (remi-php54)
               php-pdo(x86-64) = 5.4.45-13.el6.remi
           Available: php-pdo-5.4.45-13.el7.remi.x86_64 (remi)
               php-pdo(x86-64) = 5.4.45-13.el7.remi
           Available: php-pdo-5.6.31-1.el7.remi.x86_64 (remi-php56)
               php-pdo(x86-64) = 5.6.31-1.el7.remi
Error: Package: php-cli-5.6.32-1.el7.remi.x86_64 (remi-php56)
           Requires: libpcre.so.1()(64bit)
Error: Package: php-5.6.32-1.el7.remi.x86_64 (remi-php56)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-gd-5.6.32-1.el7.remi.x86_64 (remi-php56)
           Requires: libpng15.so.15()(64bit)
Error: Package: php-5.6.32-1.el7.remi.x86_64 (remi-php56)
           Requires: htt-pd-mmn = 20120211x8664
           Installed: htt-pd-2.2.15-60.0.1.el6_9.6.x86_64 (@ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-5.0.1.el6.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-9.0.1.el6.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-9.0.1.el6_1.2.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-9.0.1.el6_1.3.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-15.0.1.el6.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-15.0.1.el6_2.1.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-26.0.1.el6.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-28.0.1.el6_4.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-29.0.1.el6_4.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-30.0.1.el6_5.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-31.0.1.el6_5.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-39.0.1.el6.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-45.0.1.el6.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-47.0.1.el6_7.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-47.0.1.el6_7.1.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-47.0.1.el6_7.2.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-47.0.1.el6_7.3.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-47.0.1.el6_7.4.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-53.0.1.el6.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-54.0.1.el6_8.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-54.0.1.el6_8.1.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-55.0.1.el6_8.2.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-56.0.1.el6_8.3.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-59.el6.centos.x86_64 (base)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-59.0.1.el6.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-60.el6.centos.4.x86_64 (updates)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-60.el6.centos.5.x86_64 (updates)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-60.el6.centos.6.x86_64 (updates)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-60.0.1.el6_9.4.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
           Available: htt-pd-2.2.15-60.0.1.el6_9.5.x86_64 (ol6_latest)
               htt-pd-mmn = 20051115
Error: Package: php-5.6.32-1.el7.remi.x86_64 (remi-php56)
           Requires: libpcre.so.1()(64bit)
Error: Package: php-xml-5.6.32-1.el7.remi.x86_64 (remi-php56)
           Requires: libxml2.so.2(LIBXML2_2.9.0)(64bit)
Error: Package: php-cli-5.6.32-1.el7.remi.x86_64 (remi-php56)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


[root@zabbix remi]# yum repolist
repo id                  repo name        status
base                     CentOS-6 - Base   6,706
centos-sclo-rh           CentOS-6 - SCLo rh  5,988
centos-sclo-sclo         CentOS-6 - SCLo sclo  464
elgis                    EL GIS 6 - x86_64   198
epel                     Extra Packages for Enterprise Linux 6 - x86_64  12,444
extras                   CentOS-6 - Extras    46
mariadb                  MariaDB              18
ol6_UEK_latest          Latest Unbreakable Enterprise Kernel for Oracle Linux 6 (x86_64) 729
ol6_latest              Oracle Linux 6 Latest (x86_64) 39,576
pgdg10-updates-testing  PostgreSQL 10 6 - x86_64   227
remi-php54              Remi's PHP 5.4 RPM repository for Enterprise Linux 6 - x86_64  381
updates                 CentOS-6 - Updates  747
zabbix                  Zabbix Official Repository - x86_64     337
zabbix-non-supported    Zabbix Official Repository non-supported - x86_64 15

Re: Installing php 5.6 on centos 6

Yum shouldn't pull any el7 package, check remi-release RPM version

And follow the wizard instructions (top right link)

"Yum clean all" may help

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70