Topic: PHP 7.2 installing pthreads - zts

Hello

I am trying to install the pthreads extension but i can't seem to find a solution.
Using pecl install pthreads i get:

checking for ZTS... configure: error: pthreads requires ZTS, please re-compile PHP with ZTS enabled
ERROR: `/var/tmp/pthreads/configure --with-php-config=/usr/bin/php-config' failed

Under yum, the  php-pecl-pthreads seems to be only for php 5.4 (centos7)

Is there any other way i could install pthreads?

Thanks

Re: PHP 7.2 installing pthreads - zts

pthreads extension is currently not in a good shape...

No stable version have been released for PHP >= 7.1

See https://github.com/krakjoe/pthreads/issues


BTW,
* remi-php71 repository have 3.1.7-dev for PHP 7.1
* remi-php72-test repository have 3.1.7-dev for PHP 7.2

You can try them (and expect some bug / crash)

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: PHP 7.2 installing pthreads - zts

Thank you!