1 (edited by wilburunion 2017-12-20 15:40:09)

Topic: ImageMagick6-libs package conflicts with LibRaw-0.18

libraw.so.5 from ImageMagick6-libs-6.9.9.27-1.el7.remi.x86_64 (@remi) conflicts with libraw.so.16 from LibRaw-0.18.6-2.el7.x86_64 (epel-testing)

Resolving Dependencies
--> Running transaction check
---> Package LibRaw.x86_64 0:0.14.8-5.el7.20120830git98d925 will be updated
--> Processing Dependency: libraw.so.5()(64bit) for package: ImageMagick6-libs-6.9.9.27-1.el7.remi.x86_64
---> Package LibRaw.x86_64 0:0.18.6-2.el7 will be an update
--> Finished Dependency Resolution
Error: Package: ImageMagick6-libs-6.9.9.27-1.el7.remi.x86_64 (@remi)
           Requires: libraw.so.5()(64bit)
           Removing: LibRaw-0.14.8-5.el7.20120830git98d925.x86_64 (@base)
               libraw.so.5()(64bit)
           Updated By: LibRaw-0.18.6-2.el7.x86_64 (epel-testing)
              ~libraw.so.16()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Any plan to repackage ImageMagick6-libs OR is there a workaround ??

Since libs are sensitive and can break other things I did not want to "force" the install of LibRaw-0.18.6-2.el7.x86_64 - yet

Re: ImageMagick6-libs package conflicts with LibRaw-0.18

This should NOT happen

libRaw 0.14 (soname 5) is in base repo
EPEL must NOT override base package (repo policy)

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: ImageMagick6-libs package conflicts with LibRaw-0.18

Should be removed from epel-testing, see https://bodhi.fedoraproject.org/updates … d4de5890b2


P.S. thanks for the notice

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test