1 (edited by mvug 2018-03-02 09:25:09)

Topic: php 7.2.3-1.el7.remi

I am getting an error when upgrading PHP 7.2 on my Centos 7.2 machine.

Sorry this is in Dutch

--> Transactiecontrole uitvoeren
---> Pakket php-bcmath.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-bcmath.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-cli.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-cli.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-common.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-common.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-devel.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-devel.x86_64 0:7.2.3-1.el7.remi wordt een update
--> Verwerking afhankelijkheid: devtoolset-6-gcc-c++ voor pakket: php-devel-7.2.3-1.el7.remi.x86_64
--> Verwerking afhankelijkheid: devtoolset-6-gcc voor pakket: php-devel-7.2.3-1.el7.remi.x86_64
---> Pakket php-fpm.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-fpm.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-gd.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-gd.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-imap.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-imap.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-intl.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-intl.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-json.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-json.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-mbstring.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-mbstring.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-mysqlnd.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-mysqlnd.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-opcache.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-opcache.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-pdo.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-pdo.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-process.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-process.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-soap.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-soap.x86_64 0:7.2.3-1.el7.remi wordt een update
---> Pakket php-xml.x86_64 0:7.2.2-1.el7.remi wordt bijgewerkt
---> Pakket php-xml.x86_64 0:7.2.3-1.el7.remi wordt een update
--> Klaar met oplossen afhankelijkheden
Fout: Pakket: php-devel-7.2.3-1.el7.remi.x86_64 (remi-php72)
           Vereist: devtoolset-6-gcc
Fout: Pakket: php-devel-7.2.3-1.el7.remi.x86_64 (remi-php72)
           Vereist: devtoolset-6-gcc-c++
 Je zou kunnen proberen met behulp van --skip-broken het probleem te omzeilen
 Je zou kunnen proberen: rpm -Va --nofiles --nodigest

2 (edited by tangramor 2018-03-02 09:34:46)

Re: php 7.2.3-1.el7.remi

I just got the same error...

And I tried to specify the version to 7.2.2, but cannot find php-common-7.2.2...

I have to downgrade to 7.1 now

Re: php 7.2.3-1.el7.remi

1/ you very probably don't need the php-devel package which is only needed to build extensions, and most extensions are already available in the repository

2/ devtoolset-6 is indeed needed for consistency, to build extensions with the same compiler than php itself

3/ devtoolset-6 is available on centos-sclo repository

See https://wiki.centos.org/AdditionalResou … tories/SCL

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: php 7.2.3-1.el7.remi

I will think if I can drop this dependency

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: php 7.2.3-1.el7.remi

Dependency removed in -2 build

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: php 7.2.3-1.el7.remi

Notice however that building extensions with default gcc from base distro will very probably fail.

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: php 7.2.3-1.el7.remi

thanks man!

Re: php 7.2.3-1.el7.remi

Thank you!