Topic: ssh2 library request

I wonder if it is possible to include the ssh2 library to the collection at some distant point in the future smile

Markku

Re: ssh2 library request

libssh2 is part of the distribution, see https://rpms.remirepo.net/rpmphp/zoom.php?rpm=libssh2

My repository is mostly PHP dedicated, and the php-pecl-ssh2 package is available and use the system library.

What do you expect / need ?

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: ssh2 library request

Oh, I was talking about the PHP SSH2 extension. For some reason my CentOS 7 installation cannot find it, anyhow. I have installed PHP 7.2 from the repository with most of the extensions I need but when I try to install, this is what happens (it cannot find the extension from Remi but falls back to epel):

sudo yum install php-pecl-ssh2
...
Error: Package: php-pecl-ssh2-0.12-1.el7.x86_64 (epel)
           Requires: php(api) = 20100412-64
           Installed: php-common-7.2.4-1.el7.remi.x86_64 (@remi-php72)
               php(api) = 20170718-64
           Available: php-common-5.4.16-42.el7.x86_64 (base)
               php(api) = 20100412-64
           Available: php-common-5.4.16-43.el7_4.x86_64 (updates)
               php(api) = 20100412-64
           Available: php-common-5.4.16-43.el7_4.1.x86_64 (updates)
               php(api) = 20100412-64
           Available: php-common-7.2.3-2.el7.remi.x86_64 (remi-php72)
               php(api) = 20170718-64

I have installed PHP 7.2 and the extension (fpm,gd,json,opcache,pdo etc) from Remi:

php.x86_64                            7.2.4-1.el7.remi               @remi-php72
php-cli.x86_64                        7.2.4-1.el7.remi               @remi-php72
php-common.x86_64                     7.2.4-1.el7.remi               @remi-php72

This is the so far only extension that fails to install, cannot understand why. I have phpized and compiled it manually and added to php.ini so it works now, though. I am doing my best to avoid manual compiling, but in this case it is necessary.

Markku

Re: ssh2 library request

You have PHP 7.2 from remi-php72, so you need php-pecl-ssh2 from the same repository.
https://rpms.remirepo.net/enterprise/7/ … -ssh2.html

As explained by the Wizard (top right link), I recommend you enable remi-php72 permanently

Or you have some yum plugin which blocks the update (see explanation about "priority", again in the wizard instructions)

Else, post "FULL" yum output.

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test

Re: ssh2 library request

Thanks,

Found out that due to a typo the server installation script had failed to create a "priority" setting for the repo. After correcting that everything worked.

For some reason my eyes failed to spot the php-pecl-ssh2 in your package listing which is why I at first thought it was missing. I will blame my glaucoma for that smile

Thanks for the kick in the butt, everything OK now smile

Markku

Re: ssh2 library request

smile

Desktop: Fedora 27 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 28 x86_64 + rpmfusion + remi (SCL only)
Hosting Server: CentOS 6.10 x86_64 with EPEL, remi, remi-php72 and remi-php72-test