Topic: Depenency Problems

Hello,

I have a problem whereby I am trying to install php-ldap and am encountering dependency problems.  I keep on receiving this error as follows:

Error: Package: php-cli-7.1.10-1.el7.remi.x86_64 (remi-php71)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: php-fpm-7.1.10-1.el7.remi.x86_64 (remi-php71)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)

What I have done is actually install openssl version 1.0.21 following this website https://syslint.com/blog/tutorial/how-t … or-rhel-7/
When I check the version this is what I see --> OpenSSL 1.0.2l  25 May 2017

So I still not sure why I am seeing errors. I did install/reinstall libcrypto.so.10 but still encounter problems.

I do not want to have to uninstall php71 as a great deal of work has gone into the configuration as a Wordpress site is been setup and we are trying to get LDAP to work.

Any help would be really appreciated.

Regards,
Patrick

Re: Depenency Problems

As explained in the FAQ https://blog.remirepo.net/pages/English-FAQ#deps

RHEL / CentOS 7.4 is now the minimal supported version, and provides openssl 1.0.2

Sorry but I don't have enough resource to maintain packages for multiple RHEL poiint release.. (especially that EUS versions are only for a few users, and CentOS 7.3 is not supported anymore by CentOS team)


P.S. linked howto is a stupid one, building from sources will never help with RPM dependencies, and could destroy your installation on a such critical library.

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Depenency Problems

BTW, what is your currently installed PHP version ?

You can download an install manually the php-ldap package matching your version

This can only be a temporary solution

Desktop: Fedora 25 x86_64 + rpmfusion + remi-test + remi-dev
Laptop:  Fedora 26 x86_64 + remi (SCL only)
Hosting Server: CentOS 6.9 x86_64 + EPEL + remi + remi-php70

Re: Depenency Problems

Hello,

I am running RedHat 7.3 with PHP 7.1.9 as my versions.  I just rolled back my to my snapshot so the linked 'howto' is no longer an issue.
So I guess I have to get my server to point to a RH 7.4 repo to get the openssl installed.  Am using Satellite so when I figure that out I will update this to let you know.

Thank you very much for your help,

regards,

Patrick